This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 month, 4 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 20, 2019 at 9:43 pm #3850275

joannaP

This page was sent out for translation through the WPML plugin
hidden link

Translations were sent back but this page is not showing up in the navigation. This is supposed to be the second from the last page in the main navigation.
English: hidden link
Chinese: hidden link

I am unable to provide Debug Information. Every time I paste it into the field below your website crashes.

Plugin Name Status Active Version
WPML Multilingual CMS Installed Yes 4.2.6
WPML CMS Nav Not installed No n/a
WPML String Translation Installed Yes 2.10.4
WPML Sticky Links Not installed No n/a
WPML Translation Management Installed Yes 2.8.5
WPML Media Installed Yes 2.5.2
WooCommerce Multilingual Not installed No n/a
Gravity Forms Multilingual Installed Yes 1.5.0
Yoast SEO Multilingual Not installed No n/a

PHP INFO
Version 7.0.33-0ubuntu0.16.04.4
Memory limit 256M
Memory usage 37.97 MB
Max execution time 30
Max input vars 10000
Utf8mb4 charset Yes
Multibyte String extension Loaded
SimpleXML extension Loaded

May 21, 2019 at 5:00 am #3851871

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Could you please synchronize the menu as mentioned here:
https://wpml.org/documentation/getting-started-guide/translating-menus/

Once synchronized the menu will be there in secondary languages.

Look forward to your reply.

Thanks

May 22, 2019 at 4:05 pm #3867951

joannaP

Thank you for your response. I should have mentioned that we have sync'd the menu several times. We go to "WP Menus Sync", click the "sync" button, check all the menu boxes and click the "Apply" button. We then get a "Menus have been sync'd" message. I just did it again. The page is still not showing up in the menu. What else can we do?

May 23, 2019 at 3:40 am #3870961

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps:
- Go to Appearance -> Menus
- Select the Menu
- Change the language and add the missing page manually.
- Now Synchronize the menu again.

If the problem still exists, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

The topic ‘[Closed] A page is not showing up in the navigation’ is closed to new replies.