Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.29 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 18 replies, has 2 voices.

Last updated by hugoM-4 2 months, 3 weeks ago.

Assisted by: Prosenjit Barman.

Author Posts
November 22, 2023 at 1:14 pm #14898125

hugoM-4

I am trying to: update 1 phrase in the English translation hidden link but the page turned up in Dutch.

Link to a page where the issue can be seen: hidden link

I expected to see: Englsih texts (as the opther pages show)

Instead, I got: Dutch text

November 24, 2023 at 12:37 pm #14917289

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello There,
Thanks for contacting WPML Support.

I understand the issue you're having and will try my best to assist you in this matter.

If you have correctly added the English translation but are still seeing the Dutch contents, it might be because the Translated page remains synchronized with the default page. This often occurs while translating pages manually, more specifically, if you've duplicated the default page to create a translation.

Would you please open the Translated page in WordPress Editor and ensure that the page has been translated independently? You can check the guide below to understand the process.

- https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/#:~:text=Translate%20independently

I also can see that you're using Cornerstone page builder to add content. For your information, translation support has not been integrated yet into all Cornerstone elements. In case you use an X or Pro theme add-on that’s not yet configured to work with WPML, you can easily fix it by adding the support. For more information, please check this guide: https://wpml.org/documentation/theme-compatibility/xtheme/#translating-content-coming-from-cornerstone-add-ons

Please let me know if that helps or if you need further assistance in this matter. I will be happy to help.

Best regards,
Prosenjit

November 24, 2023 at 5:15 pm #14920051

hugoM-4

Hi, I'll show you screenshots in which you'll see the difference between translating in Cornerstone and the final result; translating in WPML-editor doesn't do anything, BTW.
I have been struggling for years now with this theme and WPML and most of the times UI fgelt lucky when it worked but whenever it works or not, I can't find a clue to it...

Scherm­afbeelding 2023-11-24 om 18.10.29.png
Scherm­afbeelding 2023-11-24 om 18.08.39.png
November 27, 2023 at 5:06 am #14926345

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello There,
I hope you're doing well. Sorry for the delay in responding due to the weekend.

Thank you for sharing the screenshot. I got a clear understanding of the issue.

To understand the root cause of the issue, a closer inspection will be required. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to have a testing site where the issue is replicated.

You will find the needed fields below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” or "All in One WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT
-Please backup site files and database before providing us access.
-If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Looking forward to your response.

Best Regards,
Prosenjit

November 28, 2023 at 8:21 am #14936485

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hi There,
Thank you for sharing the access information.

While checking, I found that you've used the Classic Elements on the Contact Page, which are not available in Cornerstone By default. The translation support for Classic Elements hasn't been added properly which is why, the contents don't appear translated in the frontend even after adding the translation properly in the Translation Editor.

To solve the issue, please follow the workaround mentioned in the Errata below.

- https://wpml.org/errata/cornerstone-classic-widgets-translations-not-displayed-on-front-end/

It is recommended to use the Standard widget instead of the classic or legacy widget. I hope the Errata will help to solve the issue.

Please let me know if that helps or if you need further assistance in this matter. I will be happy to help.

Best regards,
Prosenjit

November 28, 2023 at 10:42 am #14937749

hugoM-4

I translated manually, as you could see in the screenshots, but the translated page is not shown, that's the problem and that won't be solved with your advice, I'm affraid... or am I wrong?

November 29, 2023 at 5:06 am #14946047

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hi There,
Thank you for the update.

It looks like you created the English translation of your page by duplicating the default page. As a result, the elements of the default and translated pages are synchronized, which explains why updates on the English page are not being applied. Additionally, since classic widgets are disabled by default in Cornerstone and issues have been identified with them, we advise using Standard elements.

I've addressed the issue for now by detaching the translation from the default page and then reconnecting it manually again.

To disconnect the translation, you can follow these guidelines: https://wpml.org/faq/how-to-disconnect-translations-from-the-default-language-page-or-post/

For reconnecting the translation, here are the instructions: https://wpml.org/faq/how-to-link-already-translated-pages/

Feel free to let me know if you need further assistance in this matter.

Best regards,
Prosenjit

November 29, 2023 at 1:24 pm #14951639

hugoM-4

None of what you described here works well;
when i try to disconnect translations and update the page, translations stay connected 🙁
I had to restore a backup because even the English menu went wild, adding something I wasn't able to get rid of, neither in appearance/menu nog in customizer.

I have made 2 new pages and translated them manually and one both manually and in WPML; I made them without the classic widgets, nevertheless none of them are showing the translations.

As I had to put back a backup the login for you has changed, I'll wait for a private window to give you the password.

The new pages are: hidden link and hidden link

And hidden link and
hidden link

I really would appreciate you testing yourself the advice you are giving because until now, nothing really worked: not changing the elements in Cornerstone, not translating manually, not (dis-)connecting translations.

Thanks in advance!

November 30, 2023 at 6:42 am #14958093

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello There,
Thank you for the update.

Please be informed that before sharing the advice/solution with you, I thoroughly tested everything and ensured that the default and translated pages were no longer synchronized. Only after confirming this, I informed you that the issue has been resolved.

For your information, we already have detected an issue while disconnecting the translation. To address this, I implemented the solution outlined in this Errata (https://wpml.org/errata/wpml-4-6-7-issue-with-disconnecting-translations/) and then proceeded to disconnect the English translation from the Dutch translation.

Following this, I edited the Contact page using Cornerstone, saved the changes, and reconnected the translated page with the default page. As a result, the English translation started to display correctly on the English version of the Contact page.

Kindly disconnect the English translation by updating WPML to version 4.6.8 or implementing the solution provided in the Errata. After this, review the contents on the translated page to ensure they are correct. Once confirmed, proceed to reconnect the translated page with the default page.

Please let me know the update. If you encounter the issue again, I'd be happy to take another look. I enabled the Private box for you so that you can securely share the access.

Looking forward to your response.

Best regards,
Prosenjit

December 1, 2023 at 5:40 am #14968771

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hi Hugo,
Thank you for sharing the credentials.

While conducting tests in my development environment, I encountered some issues with Cornerstone elements while translating them using ATE. I plan to escalate this to our development team for a deeper look and will keep you informed about any progress.

However, during these tests, I observed that translations made directly through the Cornerstone Editor are always displayed correctly with the default and translated versions maintaining their connection. Could you attempt the following steps to see if they address your issue?

1. Take a Backup of your site including the database
2. Please install the latest WPML version (4.6.8) on your site, available for download in the Downloads section of your WPML account (https://wpml.org/account/downloads/).
3. Once done, follow the instructions in this video to add translations for your page: hidden link

You can also translate the page manually by following this guide: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/#how-to-use-manual-translation

I appreciate your patience and kind cooperation in this matter. Please let me know if you need further assistance in this matter. I will be happy to help.

Best regards,
Prosenjit

December 1, 2023 at 9:42 am #14970807

hugoM-4

Hi Prosenjit,

Thanks for trying to help.

First of all, I had troubles before with this site and the suggestion then was to work in Cornerstone for the translations.
That worked quite well, until recently.

I managed now to connect the Dutch and Englsig contact-pages and things seem ok now, so I will leave it for the moment (spend enough time on it already 😉

I will update WPML and hopefully I'll stay out of trouble for a while.

Thanks again for helping and have a good day!
Hugo

December 1, 2023 at 11:00 am #14971589

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hi Hugo,
Thank you for the feedback!

I'm glad to hear that you've managed to connect the Dutch and English contact pages and that things are looking better now. Once you update the WPML Plugin, the issue with connecting translation will be resolved.

However, If you need any more help in the future, feel free to reach out. I will be happy to help! Have a great day too!

Best regards,
Prosenjit

December 4, 2023 at 11:10 am #14985613

hugoM-4

I'm afraid I can't be as optimistic as you seem to be, Prsoenjit

I updated WPML and all, and created a new page hidden link
by duplicating a working existing page (with working translation)
hidden link - hidden link

Then I put the content of contact-page into this new page, and I translated it in Cornerstone... and guess what shows up on the English page: the original Dutch text.
Don't need the images to show you, just watch the url's.

So, no, I don't think the issue is resolved at all.
Sorry, have a nice day, Hugo

December 5, 2023 at 4:33 am #14992653

Prosenjit Barman
Supporter

Languages: English (English )

Timezone: Asia/Dhaka (GMT+06:00)

Hello Hugo,
Thank you for the update and Sorry for any inconvenience you had.

In my previous response, I shared a video demonstrating how manual translation via Cornerstone shows the content correctly. The video illustrates that the default page was created from scratch, without any duplicates, and to create the translation, I copied the default page.

So, instead of cloning existing pages to create the default page, Could you please create the default page from scratch and then translate it into other languages? To create the translation, you can copy the contents from the default page to the translation.

I'd like to let you know that I've escalated the issue to our second-tier team for a more detailed investigation. Rest assured, I will keep you updated as soon as I receive any new information.

Thank you for your patience and understanding in this matter.

Wishing you a pleasant day!

Best regards,
Prosenjit

December 5, 2023 at 11:42 am #14996403

hugoM-4

Tried it 3 times now, the way you told me, over and over again and just kept the last desperate try... only a few words:
hidden link
hidden link

Spending hours and hours on this 🙁

It just isn't working Prosenjit, I'm very sorry

hugoM-4 confirmed that the issue was resolved on 2023-12-08 10:35:31.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.