This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 3 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 31, 2019 at 4:40 pm #3932147

madeleineH-5

I already contacted you for this problem without getting any workable solution. Now I contact you again because many of the translation on my blog are not correct.
1 problem: I have review some of the textes and translation because of spelling mistakes. I have all correction in the translator as usual and it worked for several weeks. Now I check again and all the corrected post are like before (the version before the correction)!!!
2. problem: There is also a post which is half in french and have in english. This post was translated correctly in french and it has gone!!! When I try to put the correct french translation in the translator I can't even do it because the texts are not showing in the translator. This is the page:
hidden link

I have very soon a presse release and hope that you can give me a solution for this problem before the launch. I didn't get any solution which works from you side, so let me know what to do.

Thanks
Madeleine

May 31, 2019 at 7:06 pm #3932735

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Your previous ticket was closed automatically as we did not receive any response. I can see you did not apply the suggested settings. Please fololow up on my last request on irder to assure that your server and site meet the minimum requierements in order to run WPML.

Here the previous ticket:
https://wpml.org/forums/topic/none-of-the-translated-posts-or-pages-is-showing/

Further, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 14, 2019 at 9:27 pm #4024341

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi Madeleine,

I was able to point out the issue. If you visit a post on the WordPress Editor you will find at the bottom the Multilingual Content Setup. Somehow this was set to make posts appear as translated. I changed to to "translatable".

Now you will only need to update the translations for all affected posts. Simply click the icon to translate and mark the boxes and finally the whole post as complete. Make sure that the Translation Editor indicates that the translation is completed to 100%. Et voila!

I also made sure to syncronize the menus at WPML -> WP Menus Sync.

Anyhow, I pointed out that the theme´s language switcher always returns the URL of the respective homepage. If you wish a language switcher tha will be able to switch languages between all pages and posts of your site you might consider using ione of our WPML language switchers.

https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Kind regards
Andreas

June 15, 2019 at 9:47 am #4026297

madeleineH-5

Hi Andreas,

I just checked and now most of the blogpost in French don't show up. The Translator says it si translated 100%.

What can I do?

Thanks
Madeleine

June 17, 2019 at 4:40 pm #4037307

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As you can see the translation was successful and the post translation does exists but there seems to be a redirect issue which might be realted to the themes language switcher or another plugin.

See the translated post here:
hidden link

Did you include anz custom coding into the theme in order to make the language switcher appear? This switcher seems to cause issues with the WPML laguage switcher.

Please change to a default theme like TwentySeventeen to see if the issue might be theme related. Make sure to acitvate on of the WPML language switchers at WPML -> Languages.

If this will not solve the issue, please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

June 29, 2019 at 6:24 pm #4112761

madeleineH-5

Hello,

1. I have deactivated all plugins except WPML CMS, Translation and Translation Management without noticing any improvement. I have reactivated them since.

2 .The debug.log has very little stuff and stays empty when I load the pages that don't work.

3. I noticed most of my pages have a Multilingual Content Setup set to "Make 'Pages' appear as translated", but changing them to "Make 'Pages' translatable" doesn't work: the setting doesn't survive when I reload the page in WordPress admin.

4. The language switcher is a dead-simple javascript pasted in the Divi "Integration" theme options. It's just a link to /fr/ or / which highlights the right entry by looking at window.location. It's just not possible for it to interfere and lead to a 404 page.

Meanwhile, the problem persists:

This page is built with Divi and has a "Blog" module with 4 posts, it works fine in English, but in French the "Blog" module is empty:
hidden link
hidden link

This page is built in the same fashion: it has a Divi "Blog" module with 2 posts BUT Its translated version works just fine:
hidden link
hidden link

I don't understand why the Divi Blog module is empty on some translated pages and works in others.

Please help!

July 1, 2019 at 2:09 pm #4119977

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

As mentioned in one of my earlier messages the page "Portraits" was set to "appear as translated" in the Multilingual Content Setup of its page editor. I changed to to "translatable" and retranslated the page. All blogs show up in french and the redirect works fine for the blogs.

I am not sure what you refer to by "the setting doesn't survive when I reload the page in WordPress admin". Could zou please clarify this issue? did you make sure to click the "apply" button in the right button corner of the Multilingual Content Setup and and update the page?

The language switcher always redirects to the English or French homepage respectively, which is not normal behavior but seems to be caused by the theme.
In order to verify the issue I have enabled the WPML footer language switcher at WPML -> Languages. Using this language switcher the recirect works just fine.

I further can see that the current used Divi Theme Version 3.23.3 is outdates, please update the theme.

Let me know if you need further assistance.

Kind regards
Andreas