This thread is resolved. Here is a description of the problem and solution.

Problem: Spanish posts appears on English frontpage

Solution: The user created by mistake a Spanish post with a double entry under two different language domains. Deleting the Spanish post on the English post section solved the issue.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by adoneB 1 year, 7 months ago.

Assigned support staff: Andreas W..

Author Posts
December 17, 2018 at 6:12 pm #3009800

adoneB

Please have a look at the homepage URL (my website is still under construction)

You can see a post in Spanish appearing mixed with the original English language one.
It shouldn't be there right?

What could possibly went wrong?

thanks in advance

December 17, 2018 at 9:51 pm #3010333

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I realized that there is one post in Spanish that does appear on two URLs.

hidden link

and

hidden link

Further, the post on the last URL which belongs to your English website does not have any content. Could you please verify if the post appears when check your WP admin Dashboard -> Posts and then filter for each language (English and Spanish).

It seems to me there has simply been added Spanish post inside your content for English posts that is not somehow linked to the original Spanish post. Could you please confirm that and if possible provide some screenshots from your English posts and your Spanish posts so that I could make myself a picture of the situation?

Best regards,
Andreas

December 18, 2018 at 12:36 am #3010494

adoneB

By mistake I created that post. It was sufficient deleting it and voilá, problemn solved