This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: this fatal error shows if you try to create a product translation: Fatal error: Call to a member function get_translator_id() on a non-object in /home/content/00/11445900/html/2018/wp-content/plugins/wpml-translation-management/classes/menu/translation-queue/class-wpml-translations-queue.php on line 42

Solution: reinstall WPML from scratch because it seems the database became corrupted during the installation.

This topic contains 17 replies, has 3 voices.

Last updated by widiA 1 year ago.

Assigned support staff: Laura.

Author Posts
October 4, 2018 at 9:51 am #2787080

tyroneC

Warning: debug_backtrace() expects at most 1 parameter, 2 given in /home/content/00/11445900/html/2018/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-debug-backtrace.php on line 93

the above warning message shown on my Product page --> Language

October 5, 2018 at 2:47 pm #2791125

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

these you see are PHP warnings, not errors, and can mostly be ignored if you don't experience other issues. Probably you see them because you have WP debug enabled.

Check your wp-config.php for the following lines:

define( 'WP_DEBUG', false );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Probably you have the first or last one set up as "true". If you change them to "false" the message should disappear.

October 6, 2018 at 6:34 pm #2793047

tyroneC

my published product missing after I active WPML

October 7, 2018 at 5:15 am #2793485

tyroneC

Fatal error: Call to a member function get_translator_id() on a non-object in /home/content/00/11445900/html/2018/wp-content/plugins/wpml-translation-management/classes/menu/translation-queue/class-wpml-translations-queue.php on line 42

October 8, 2018 at 10:34 am #2795582

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

may I ask you where do you get this fatal error? There is something specific that triggers it?

As for your post missing, probably they don't have attached a language.
Please try as follows:
- backup your site and database
- go to WPML -> Support -> "troubleshooting" link
- click on "set language information"

Let me know if this fix the products issue.

October 8, 2018 at 10:39 am #2795649

tyroneC

Hi , i did click everything in troubleshooting yesterday , but no luck it doesnt help, where can i provide the login information for your checking ?

October 8, 2018 at 11:14 am #2795754

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if yours is a live site and not a development site there isn't much I can do even if I have credentials, as I can't perform operation or tests.

Can you explain me your procedure for creating products? And how is the fatal error related to this?

October 8, 2018 at 11:17 am #2795757

tyroneC

Hi , it is a developing site, you can perform any test you want

October 8, 2018 at 2:41 pm #2796457

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I enabled a private answer so you can share credentials with me, but I still need to know your procedure and where I can see the error/if there is something that triggers it.

October 8, 2018 at 3:24 pm #2796672

tyroneC

To trigger the error
1. enable wpml
2. create a product
3. after click publish, the page redirect wpml page
4. but both language show a "+" sign
5. the Fatal error I posted above will show if I click either "+" sign

October 8, 2018 at 3:27 pm #2796678

tyroneC

and the register button seem not work now, it ask me to register the wpml,but I did this yesterday already.and when I click it now, it do not show me the register screen

October 9, 2018 at 9:15 am #2799111

tyroneC

no error show if I downgrade to 3.9.7, is there any different requirement from 3 to 4?

October 9, 2018 at 9:41 am #2799159

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

there are no different requirements from version 3 to 4.
I did some test on your site, I deactivated all plugin except WooCommerce and WPML + addons and doing as you said I don't get the fatal error, but I don't get the translation page either.

I'd suggest you remove the plugin you don't need (I see there are several of our bridge plugins but if you don't need them it's better not to have them on your site) and try to figure out if there is some incompatibility issue.

I see 7 product in your product page, even if only one in English and one in Chinese. When did you create them? It was before installing WPML?

October 9, 2018 at 9:48 am #2799185

tyroneC

Hi, all products created in English first, when I want to translate it to Chinese, it show error.

October 9, 2018 at 10:17 am #2799443

tyroneC

0.jpg only 5 plugin activated
1.jpg after publish a product, this screen show, and nothing can do

since this is a testing site, you can delete anythings if you think may help to fix the problems.
I just want it works, thanks.