Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 3 voices.

Last updated by shaneB-8 1 year, 8 months ago.

Assisted by: Osama Mersal.

Author Posts
August 1, 2022 at 1:01 pm #11777123

shaneB-8

Hi there,

My client seems to be having an issue whereby they modify a Woocommerce Product translation but it is never saved. What is odd is that one of the products seems to have a translation that is worded as "Reservation" as though it is linked to a Woocommerce Booking, but I can't be certain whether that was a manual issue or not.

I read through another ticket and performed the suggestions to run the following:
+ Clear Cahce in WPML
+ Remove ghost entries
+ Fix elementy_type
+ Fix WPML tables collation
+ Assign translation status to duplicated content
+ Set language information

On the last one I am receiving the following errors (and it has yet to finish)

[01-Aug-2022 13:00:22 UTC] PHP Fatal error: Uncaught InvalidArgumentException: element_id and type do not match for element_id:6784 the database contains post_revision while this function was called with post_wc_booking in wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:34
Stack trace:
#0 wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1522): WPML_Set_Language->set()
#1 wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(359): SitePress->set_element_language_details()
#2 wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(203): WPML_Post_Translation->maybe_set_elid()
#3 wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-frontend-post-actions.class.php(44): WPML_Post_Translation->after_save_post()
#4 /var/www/package/ist in wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php on line 34

August 1, 2022 at 1:55 pm #11777481

Bruno Kos
Supporter

Languages: English (English ) German (Deutsch ) French (Français )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Would you be willing to provide me with WordPress credentials so I could investigate the issue directly?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

Regards,
Bruno Kos

August 1, 2022 at 1:59 pm #11777651

shaneB-8

Let me know whatever additional information I can provide and I can do that. Thanks so much for your support.

August 1, 2022 at 2:20 pm #11777811

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

Could you please apply the following steps:

1- Go to WPML-> Support-> Troubleshooting
2- Run the troubleshooting functions one by one (Kindly check this )
3- Edit the product in the default language
4- Add "V2" to the title and update the product
5- Delete the "V2" and update the product
6- Try to translate the product and save it
7- Clear the cache and check the front end

❌ Please backup your database before performing the above steps❌

If these steps didn't help, I need your permission to take a local copy of your site to debug the issue without affecting your live site.

Thanks for your cooperation

Regards,
Osama

August 1, 2022 at 2:47 pm #11778243

shaneB-8

Hi there,

I don't really understand steps 4-5. I need to rename it, save it, and then delete it? Wouldn't I just delete the product?

August 1, 2022 at 2:55 pm #11778259

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

1) These steps are for force updating the database and updating the translation.

2) When you edit the product in the default language and switch the language from the top admin bar, you will see that the booking product has been deleted. (hidden link)

Would you please check if you have any deleted products/bookings?

Thanks,
Osama

August 1, 2022 at 3:11 pm #11778401

shaneB-8

Ok thanks for clarifying. I'll run through the troubleshoot items. I imagine I don't click on "Reset languages" since that's going to reset everything right?

August 1, 2022 at 3:13 pm #11778427

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I didn't upload the image; sorry for that. Kindly run the troubleshooting functions one by one.

Thanks,
Osama

1.jpg
August 1, 2022 at 4:10 pm #11778791

shaneB-8

Hi there,

There are no products that appear deleted at least in the WP view. The translation is properly broken after changing the name, but then Woocommerce Bookings seems to re-attach the booking to the actual product again.

I'm included to remove this booking since it is quite old anyways. Do you think this might resolve the issue? It seems that Woocommerce Bookings is attempting to link to the translation before it is complete, and therefore causing this broken element.

August 1, 2022 at 4:13 pm #11779023

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi

Thanks for your update. If this issue happens only on this product, that could be caused because the booking is old, as you said, so removing the booking or creating a new one could fix the issue.

Regards,
Osama

August 1, 2022 at 4:35 pm #11779169

shaneB-8

Yeah I'm struggling to determine how to do that. IN the meantime, I came across the translation (perhaps the old one that should be linked) here : hidden link

I cannot for the life of me link that to the French version though. Any clues? I tried using the Connect with translations but when it searches for the terms it never come up with my other product.

August 1, 2022 at 4:39 pm #11779171

shaneB-8

Huh this is exactly the issue actually. For some reason the translated items ended up being set to French. I set one of them back (Sud-Est) and then linked the English to the French and that one is totally fine now.

August 1, 2022 at 4:57 pm #11779201

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

1) I've created a test product and translated it without issues. Kindly check it here. (hidden link)

Would you please let me know the steps to reproduce the issue?

2) If you can replicate the issue from scratch, it would be great to isolate and reproduce it on a fresh installation. Kindly login to this sandbox site and upload only WooCommerce booking plugins. (hidden link)

After that, please create a couple of bookable products and accommodation to check if the issue is replicable on a fresh installation.

Thanks for your cooperation

Regards,
Osama

August 1, 2022 at 5:04 pm #11779213

shaneB-8

Yeah that's not my issue. The issue is that somehow these products lost their translations. After working with you I realized that somehow they ended up being set (the translations) as French. I switched them back and then used the "Connect with translations" to relink most of them (while we were chatting).

What I _cannot do_ is synchronize the last one. Is there something that I can do in the database to do this myself?

+ English that should be linked to French version: hidden link
+ French version hidden link

Clicking on the Connect button only get's me a list of the English versions and it indicates that they are in [Fr]. Actually it shows me that there are three which isn't te case. There not even in the trash so where is this coming from....

Peek 2022-08-01 14-04.gif
August 1, 2022 at 5:50 pm #11779379

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your feedback. There are four products with almost the same names in French, and that's why you see more than suggestions when trying to connect the product. (Kindly check the attached screenshot)

I've connected the English product to one of them, and I think you might need to delete the duplications. Kindly check the following URLs for the product and its translation:

EN: hidden link

FR: hidden link

There are some other products with this duplication issue, such as:

  • Day Camp
  • Family Camp
  • Camp de jour
  • Bedroom
  • Best regards,
    Osama

    1.jpg
    This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.