This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 20 replies, has 3 voices.

Last updated by Yvette 6 days, 2 hours ago.

Assigned support staff: Yvette.

Author Posts
September 17, 2019 at 3:41 am #4585395

raymondL-8

I am trying to: Add a custom product addon of pricing to the product under the product page but when i check the box and click update, then the check box become unchecked. And I only can check the box of the addon pricing on the default language of traditional chinese. I am using Acoweb's woocommerce custom product addons which is compatible with wpml
hidden link

Link to a page where the issue can be seen:

I expected to see: I expected to see the checkbox gets saved

Instead, I got: It become unchecked after clicking the update button.

Please kindly looking into this and I really appreciated your team support.

September 17, 2019 at 5:36 pm #4590461

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Indeed, this plugin should be working well with WPML + WCML.

Please do the following steps:
1. Loin to this sandbox site which has been pre-configured with WPML/WCML/Woocommerce
Login:hidden link

2. Upload and configure the Custom Product AddOns plugin

3. Prepare a **simple** example of the issue you are encountering

4. Write back with steps on how to see the error on this sandbox site. Be detailed and clear - use screenshots where necessary for clarity.

Thanks

September 18, 2019 at 7:04 am #4592839

raymondL-8

Dear Yvett,

Please see the attached document. I am not being able to replicate the same problem on the sandbox. This is showing fine. hidden link

Please kindly look into what went wrong with my site. Please send private message for accessing to my site details.

thx, ray

September 18, 2019 at 7:05 am #4592841

raymondL-8

Dear Yvett,

Please see the attached document. I am not being able to replicate the same problem on the sandbox. This is showing fine. hidden link

Please kindly look into what went wrong with my site. Please send private message for accessing to my site details.

thx, ray

September 18, 2019 at 1:36 pm #4597171

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

September 18, 2019 at 5:00 pm #4599245

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. You wrote: "...when i check the box and click update, then the check box become unchecked..."

Where are you trying to check the box and click update? On the wordpress product editing screen?

Please detail steps on how to reproduce the error on your site and be specific since I cannot read chinese =(,.

2. Have you already checked the configuration and versions of the plugins installed?
3. As a Diagnostic step, if you temporarily reduce your site´s configuration to be the same as the sandbox site, do you still encounter the problem? e.g. temporarily change your active theme to "Storefront" and temporariliy deactivate all non-WPML plugins

I wait for your response.

September 21, 2019 at 6:29 am #4615473

raymondL-8

Yes i will work on it this weekend.

September 23, 2019 at 2:07 pm #4624863

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok . thank you for your collaboration on this.

September 23, 2019 at 4:57 pm #4625759

raymondL-8

Dear Yvette,

I think the problem is caused by the "WPML Multilingual CMS" plugin. When i deactivate this plugin, i will be able to save the custom product addon. But then another problem arises when the plugin being disabled, other language product pages are not picking up the addons, and the plugin only allows me to save the custom product addons on the default language only, so the other two langauges that i have wouldnt pick up the addons.

Thx,
Ray

September 23, 2019 at 8:20 pm #4626495

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes - you definitely need the WPML CMS plugin for any kind of languages to work.

I had asked you earlier to please clarify some points. Can you please answer these questions:
================================
1. Where are you trying to check the box and click update? On the wordpress product editing screen?

Please detail steps on how to reproduce the error on your site and be specific since I cannot read chinese --OR-- upload a screenshot of where you are trying to check the box for update.

2. Have you already checked the configuration and versions of the plugins installed?

3. As a Diagnostic step, if you temporarily reduce your site´s configuration to be the same as the sandbox site, do you still encounter the problem? e.g. temporarily change your active theme to "Storefront" and temporariliy deactivate all non-WPML plugins

non-WPML plugins ONLY

September 24, 2019 at 2:13 am #4627163

raymondL-8

1. Just go to the default language product page, and then click on "Custom Product Addons" tab, then check the box of the Custom Product Addon forms. Since you can only set it up on the default language of the website, the other two languages should have the same Addon form applied without adding to individual language page.
2. I have checked the configuration and plugin.
3. As i said when i disable the "WPML Multilingual CMS", it will allow me to save the form to the product in the default langauge but when i activate the "WPML Multilingual CMS" again, it doesnt show up on the other language interface.

Thx for looking into this.

September 24, 2019 at 12:43 pm #4631669

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I created a new product and it´s English translation here:
hidden link
hidden link

This seems to work fine - do you agree?

Is the issue only ocurring with older products? Can you provide a product that I can test with?
Thanks

September 25, 2019 at 4:46 am #4635617

raymondL-8

It seems to be with older product, can you please hidden the product link above. Can you let me know the procedure of setting up your sample product? Do you know check the box once on the product's default language which is zh-hant? thx for supporting

September 25, 2019 at 3:07 pm #4640257

raymondL-8

Sorry i have deleted the sample product you created because the site is running live.

September 28, 2019 at 12:54 am #4656961

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Yvette is absent at the moment, I would like to take care of your ticket from now.

As I understand it, the problem you are reporting is that you are unable to enable the "Custom Product Options" option.

The WPML by default only locks default WooCommerce options for the secondary languages that need to be synced. If you can't enable the "Custom Product Options" option in the secondary language, this is not related to WPML, but to the "WooCommerce Custom Product Add-ons" plugin that is preventing this change from being made - and the plugin author should probably have some reason for it.

Also, I'm not sure which of these options I should select for this page, for example, see the attached image.

Thank you.