This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Jamal 2 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
July 12, 2019 at 11:49 am #4198299

nxl1107

Hello,

My web site getting a lot of 500 Internal server error(Request exceeded the limit of 10 internal redirects due to probable configuration error").

I want to do this bug to be fix asap.

Regards,

July 12, 2019 at 3:16 pm #4200079

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, do you still get the redirect error?

July 12, 2019 at 3:35 pm #4200153

nxl1107

Hi,
Thank you for message.
I will send you debug log for now.
It seems same error...

[12-Jul-2019 15:29:45 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:45 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:46 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:46 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:46 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:46 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:49 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:49 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:49 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:49 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:51 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:51 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:51 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:51 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:52 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:52 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:54 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:54 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:54 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:29:54 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:03 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:04 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:04 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:04 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:04 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:07 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:07 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:07 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:07 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:08 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:08 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:09 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:09 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:27 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:27 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:28 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:28 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:36 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:36 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:36 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:36 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:43 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:43 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:44 UTC] PHP Warning:  include(/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95
[12-Jul-2019 15:30:44 UTC] PHP Warning:  include(): Failed opening '/home/wp-server/hogehoge.com/public_html/wp-content/advanced-cache.php' for inclusion (include_path='.:/opt/php-7.2.17/data/pear') in /home/wp-server/hogehoge.com/public_html/wp-settings.php on line 95

Regards

July 12, 2019 at 3:42 pm #4200171

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sharing. The only thing showing there are warnings, I'm not seeing any fatal errors.

Please complete the next steps of testing your site with only WPML plugins and a default theme, and let me know if the issue is resolved with these settings. If it is, you can then activate the rest of the plugins one at a time and see if the error can be reproduce after a certain plugin.

July 13, 2019 at 1:04 am #4201917

nxl1107

Hello,

I stopped WPML plugin and it was issue is resolved.
WPML plugin change the RewriteBase of .htaccess?

Becase i opened .htaccess then this condtion↓

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

But i saw the Thai language page(ex.hidden link) then it changed RewriteBase↓

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /th/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /th/index.php [L]
</IfModule>
# END WordPress

I think it is the issue of this.

July 15, 2019 at 4:35 pm #4213279

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I understand that the issue resolved when you deactivated WPML. It could be that there is a plugin or theme conflict, so I'd like you to test the opposite. Please leave WPML active and then deactivate the other plugins and temporarily switch to a default theme. With those settings, does the issue still happen?

Also, if you switch to default permalinks, do you still get the redirect error?

July 16, 2019 at 6:49 am #4216683

nxl1107

Thank you for message.

I can not that test because this website already public and can not stop some plugins...

I want try to add this code.
Is it same issue?
https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

Thanks,

July 16, 2019 at 3:17 pm #4221659

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It could be related if you have a 3rd party plugin that is calling flush_rewrite_rules(true) function too often. . You can try adding that code to functions.php to see if it resolves the issue. If it does not, you can send me a copy of your site so that I can test locally and try and see if I can find the cause. This will allow me to deactivate plugins locally so your live site won't be interrupted.

July 18, 2019 at 8:30 am #4236001

nxl1107

Hello,

>If it does not, you can send me a copy of your site so that I can test locally and try and see if I can find the cause. This will allow me to deactivate plugins locally so your live site won't be interrupted.
Thank you so much.
would you do that test?

Thanks,

July 18, 2019 at 3:09 pm #4240021

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

July 18, 2019 at 6:14 pm #4241713

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the files, I was able to setup a copy of your site but I am not able to reproduce the redirect error. Can you tell me specifically the steps to recreate it? What URL you are going to, what you are clicking on, etc so that I can try to reproduce in the test site? Thanks.

July 18, 2019 at 11:28 pm #4242547

nxl1107

Hello,

Can you remove code from functions.php that we talked before?

And first of all please change some languages and go to some product pages.
For example, change to "Taiwanese language" from English and go to some product pages.

Regards,

July 22, 2019 at 10:23 am #4255885

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

This is Jamal from the Support team, My colleague Lauren has passed this ticket to me because she noticed performance issues on your website, and I will be debugging those to understand the cause as part of our performance project for String Translation.
https://wpml.org/2019/06/wpml-4-2-7-and-a-preview-for-next-major-updates/

Before beginning to troubleshoot the performance issues, first, I would like to make sure that the 500 error is resolved. So I visited several languages on your website and went through several pages(products and pages) but I could not reproduce the issue, I did not get any 500 errors.
Can you please tell us a specific page or workflow that generates the 500 errors.

Best regards,
Jamal

July 23, 2019 at 12:47 am #4261867

nxl1107

Hello Jamal

Thank you for message.

I can not reproduce the issue because I added this code to functions.php
https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

But i think this isn't a real solution to the problem.
What do you think?

Thanks,

July 23, 2019 at 2:49 pm #4267181

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I think that it is a viable solution. I usually suggest in similar cases to set the .htaccess file as read-only on the filesystem level, this way it won't be overwritten by anything.
Let me know what do you think about it.

I'll now debug the performance issues noticed on your website and I'll let you know about my finding as soon as possible.

Best regards,
Jamal

The topic ‘[Closed] About Internal Server Error 500’ is closed to new replies.