This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The language switcher does not align with the menu.

Solution:
Theme or plugin is adding a height to the language switcher.
Add this CSS code to WPML > Languages > Language switcher options > Additional CSS

.fusion-main-menu > ul > li.wpml-ls-item > a { height: 40px; }

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by chong-hyor 4 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 27, 2019 at 12:46 pm #3897235

chong-hyor

Hello
I tried to use wpml .
I purchased today.
And I add language

It is okay,

But as you see in the link below,
hidden link

The menu for language text is not in fit position,
As you see in the attached file.
It is unbalanced.

It would be great, you let mw know about this.

Thank you,
Your regards chong hyo, Rhee

May 27, 2019 at 2:26 pm #3898353

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Your theme or plugin is adding a height to the language switcher.
Add this CSS code to WPML > Languages > Language switcher options > Additional CSS

.fusion-main-menu > ul > li.wpml-ls-item > a { height: 40px; }

Let me know how it goes.

Regards,
Riffaz.

May 27, 2019 at 2:33 pm #3898399

chong-hyor

My issue is resolved now. Thank you! indeed.

May 27, 2019 at 2:34 pm #3898403

chong-hyor

Thank you
for your reply.

IT works.

and I ask about plugin
I use 'the grid' plugin

It is not work in wpml.

May I do not know about using this.
It would be great, You let me know about using ...

Thank you,
Your regards CHonghyo, RHee

May 27, 2019 at 2:43 pm #3898551

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are welcome.

This ticket is closed.

Please open a new ticket for your new question to avoid the confusion and to reduce the waiting time.

Regards,
Riffaz.

May 31, 2019 at 3:13 am #3927577

chong-hyor

My issue is resolved now. Thank you!