This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by nxl1107 3 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
July 1, 2019 at 10:14 am #4117727

nxl1107

Hello,

I installed "Yoast SEO" and "Yoast SEO Multilingual".
I changed noindex of default page but return to an original setting when i changed another languages same setting.

Please check video.
hidden link

Regards,

July 1, 2019 at 11:01 am #4118157

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

It seems the resources to save this setting is not enough.
Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If still issue persists, please enable error reporting at you site as I need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
define( 'SCRIPT_DEBUG', true );

After adding the above code please try to reproduce the issue and this will create debug.log file in your site's wp-content directory. Please send me its contents.

Thank you,
Riffaz.

July 1, 2019 at 1:48 pm #4119611

nxl1107

Hello,

Thank you for message.

>Minimum requirements for WPML are 128Mb
I changed 256mb.

>To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:
I changed my wp-config but i can't see debug file.

Regards,

July 2, 2019 at 4:49 am #4124019

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for checking as instructed.

Let me know your site login details to check this.
The next reply is private.

Regards,

July 2, 2019 at 11:31 am #4126371

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

hi,

I could not type these letters : hidden link

Regards,

July 2, 2019 at 11:38 am #4126389

nxl1107

Sorry i disabled that!

July 3, 2019 at 4:29 pm #4138171

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Riffaz is sadly now available today but I am very glad to be able to assist you.

I have added a custom XML config into the WPML setting sin order to set the respective custom field for the Yoast no index to "translate".

<wpml-config>
    <custom-fields>
        <custom-field action="translate">_yoast_wpseo_meta-robots-noindex</custom-field>
    </custom-fields>
</wpml-config>

Then I changed the setting for the Cart page on the English and Candian site.

The changes are saved now.

Kind regards
Andreas

July 5, 2019 at 1:41 am #4146667

nxl1107

Hello!
Thank you so much.
My issue is resolved now. Thank you!

Regards,