This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.28 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 7, 2019 at 10:52 am

tomE-8

I am trying to:
Save custom fields contents, Related product (not even loading options) and Short description not working / saving. Also the Custom fields box at the bottom of the post admin page is incorrect, missing these fields.
same thing is working fine in other sections of the site.

Link to a page where the issue can be seen:
hidden link
(in wp admin)

I expected to see:
Saved ACF fields

Instead, I got:
Not saving.

May 7, 2019 at 11:38 am #3757305

tomE-8

We also have the same issue in our local dev environment.

May 7, 2019 at 1:23 pm #3758215

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Note: Please visit this link where you will find our official documentation on how to translate custom fields using WPML: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 7, 2019 at 2:55 pm #3759467

tomE-8

We followed all the steps and increased memory to 256M. Unfortunately, the fields are still not showing. It didn't fix our problems.

Thanks,
Tom

May 7, 2019 at 4:26 pm #3760403

tomE-8

Some more details on the problem. Everything was working fine, we then duplicated some existing fields (story custom fields) to the posts. Some field types are working, but textarea and relationship fields are not. The homepage broke after we created the arabic version.

May 8, 2019 at 6:35 am #3764077

tomE-8

Can you help?

May 8, 2019 at 10:44 am #3765677

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tom,
Thank you very much for your feedback.

I was able to reproduce the issue in the live site. In order to isolate the cause of this issue I have created a test site with a fresh new WordPress installation, including WPML and Woocommerce plugins.

I kindly ask you install the ACF plugin and recreate the issue in this test site. You can access the test site directly by following this link: hidden link

Were you able to reproduce the issue in the test site?

Regards,
Carlos

May 8, 2019 at 11:48 am #3766223

tomE-8

Hi Carlos,
we reproduced the issue in the test site you set up. This is what we did:
- added acf pro
- added acfml.1.2
- imported acf group for post
- added product
products not showing in relationship box, short description not saving in post
hidden link

Thanks,
Tom

May 8, 2019 at 1:08 pm #3767007

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tom,
Thank you very much for your message.

I will take a deeper look at the issue in the test site and I will try to isolate the cause of the issue. I will get back to you as soon as I have an answer.

Thank you very much for your patience.
Best regards,
Carlos

May 8, 2019 at 6:14 pm #3769923

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tom,

I deactivated all WPML plugins and the issue persists, which means that the cause of the problem is not related to WPML. You can see in the test site that WPML plugins are deactivated and the issue still continue happening.

In this case I recommend you to contact the suppert service of the ACF plugin and let them know about this issue.

Regards,
Carlos

May 9, 2019 at 9:14 am #3774469

tomE-8

Hi Carlos,
we have reset our installation and removed all wpml plugins and just installed ACF. Saving works fine in this setup. Adding the wpml plugin, and it's not saving again. It's definitely an issue related to the interplay of ACF and wpml, but it's not an ACF only issue. Can you have another look?

Thanks,
Tom

May 9, 2019 at 2:53 pm #3777435

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tom,
Thank you for your feedback.

Yes sure, I will take another look at the issue and see if I can find its cause.

Regards,
Carlos

May 9, 2019 at 2:57 pm #3777453

tomE-8

Hi Carlos,
we found the issue, it had to do with ACF (we had to downgrade the version) and setup. Thank you for all your help!

Tom

May 9, 2019 at 6:06 pm #3778647

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Tom,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos