This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bigul 4 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 31, 2019 at 12:48 pm #3930529

Darius Roževič

I am trying to:

Translate ACF custom fields

Link to a page where the issue can be seen:

hidden link

I expected to see:

All ACF custom fields

Instead, I got:

Only page title

May 31, 2019 at 6:54 pm #3932721

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

June 3, 2019 at 5:20 pm #3944791

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I went through the pages. One of the pages (*Paieška*) is not showing the Custom Fields.

How you are managing the Page Templates? Because the Page template options are not shown in Page Edit screen.

Please check the attached images for more details and let me know your feedback. Let me know the correct steps to reproduce the issue if I am wrong.

--
Thanks!

Bigul

June 4, 2019 at 8:12 am #3949119

Darius Roževič

Hi,

That one page doesn't have any fields, it's ok with that one.

Let's focus on this page, called "Ką veikti", it is here: hidden link

And the field group for it is here: hidden link

June 4, 2019 at 3:48 pm #3953471

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But sorry I am not able to reproduce the issue exactly. Please let me know the exact steps to reproduce the issue.

--
Thanks!

Bigul

June 4, 2019 at 4:02 pm #3953567

Darius Roževič

Hi,

When I am trying to translate fields, they are not showing in the translation screen.

For example let's take these 2 fields (although there are more if you would switch between tabs): hidden link

And when translation screen is opened, there are no fields except for the title:
hidden link

So in summary, there are no ACF fields in translations screen, but they do exist.

June 5, 2019 at 9:45 am #3958553

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have changed the translation preference of those fields. Please check the attached images.

Now the translation of *Ką veikti* page is *In progress* state. So please complete the translation. Then make a minor change in the *Ką veikti* page to refresh the translation settings and make sure you are getting the expected result or not.

--
Thanks!

Bigul

June 5, 2019 at 11:00 am #3959695

Darius Roževič

Hi,

Thanks, it seems to be working fine now. What I don't really understand is why there are 2 same options in different places? If I create a new custom field, I should check it as translatable in field settings and then also do the same in the "Multilingual content setup" box for field to become translatable?

hidden link
hidden link

June 5, 2019 at 5:56 pm #3963205

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The custom field settings are global settings. We are getting the same settings in *Multilingual content setup* box and *WPML>>Settings>>Custom Fields*. Please check the following documentation.

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

In this case, those custom fields are included in Page with a different field name. So we have to set a translation preference for it. Please check the attached images and let me know your feedback.

--
Thanks!

Bigul