This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 3, 2019 at 7:24 am #4132609

cecileG

our site is in english and there is the possibility of passing in french. we updated the plugins to version 5.8.1 but we tested before we had the same problem.
the ACF fields appear only in the French language and not in the default language when the WPML plugins is activated. When disabling the plugins the fields reappear.
the plugins of WPML Multilingual CMS is in version 4.2.7.1 it also had an update but we also checked before the update.
We tested to include a new ACF field and this one appeared. We also tried to modify the field that did not work with the parameters of the fields that had just been created and nothing has changed. what can you advise us to do?

July 3, 2019 at 10:11 am #4134493

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I would like to direct you to a relevant article from our documentation which should contain all the information you need to know. https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

If there is anything missing, or you'd like clarifications, I am here to help. Just drop a reply here so I can help you further.

Thanks

July 4, 2019 at 2:48 pm #4144665

cecileG

despite your tutorial, quite well documented, none of the solutions worked. the ACF fields are still not visible in the page where they should be. i am trying to change all possible ACF values ​​but unfortunately nothing is done. If I create a new group of fields this one appears so I do not understand the problem.

July 5, 2019 at 3:20 am #4147213

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Strange, could you please provide me login details with the page and fields links so I can check the issue further?

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

July 8, 2019 at 4:23 am #4158993

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The login detail is not working, so could you please check it again once?

You can edit your previous private reply to send the updated details.

Look forward to your reply.

Thanks

July 9, 2019 at 6:47 am #4167803

cecileG

Hello,
I updated the connection data.
thank you for your patience

July 9, 2019 at 7:09 am #4167927

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The settings for the repeater fields are not set correctly as a reason the issue is happening, set the repeater field "chiffres_cles" as mentioned here and the issue will be solved.

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Let me know if this helps.

Thanks