This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bigul 3 months, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 19, 2019 at 4:52 am

edn-4

I am trying to: am trying to translate acf filed text will translate successfully but image not work fine.

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

note. am already open this issue two time but no one provide me best solution. every one said read document am already follow the doc and nothing to achieve. now am very frustrated.

June 19, 2019 at 10:14 am #4050567

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Just to make sure, this issue is same the following tickets, am I right?

https://wpml.org/forums/topic/need-help-to-translate-acf-field/

https://wpml.org/forums/topic/acf-content-not-displaying-after-translation/

If so, Raja is currently debugging the issue and will get back to you soon. It will help us to avoid duplicate tickets.

Thank you for your understanding. Please let me know your feedback.

--
Thanks!

Bigul

June 19, 2019 at 10:34 am #4050757

edn-4

raja is not able to help me out that's by am here. can you help me out or not ?

June 19, 2019 at 12:42 pm #4051545

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please choose *Copy* as the translation preference a couple of the ACF Image fields having the issue. After that update the Homepage and its translation(just resave to refresh the translation settings), then check you are getting the expected result or not.

--
Thanks!

Bigul

June 19, 2019 at 12:52 pm #4051621

edn-4

am doing the same as your instruction but still same issue and also updated text not reflected on site.
like if am change a text in Chinese language, text same as default language.

June 19, 2019 at 5:51 pm #4053675

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The *member_background* and *future_image* fields are still showing *Translate* as the translation preference in *Multilingual Content Setup* widget of the Homepage edit screen. Please check the attached images.

Please change it as *Copy* and apply the changes. Then update the Homepage and its translation(just resave to refresh the translation settings), and check the issues are existing or not.

--
Thanks!

Bigul

June 20, 2019 at 5:53 am #4056753

edn-4

home translated but am doing the same thing on all other pages but still images missing.
wpml is taking time to translate the things ?
can you look for other pages. what am wrong

June 20, 2019 at 1:33 pm #4060241

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. This may be happening because of the compatibility issues. Please upgrade to the latest version of *Advanced Custom Fields PRO* after a full site backup and try the steps recommended by Raja. Hope it will help you to resolve the issue. Please let me know your feedback.

--
Thanks!

Bigul

The topic ‘[Closed] ACF field not translate correctly’ is closed to new replies.