This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Raja Mohammed 6 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 4, 2019 at 5:34 am #3532109

sophiaH-2

I am trying to: change acf field image but after update page it is not update with new page it is showing old image.

I expected to see:

Instead, I got:

April 4, 2019 at 7:07 am #3532747

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi There,

I have checked this issue with the developer of ACFML plugin, He is suspecting to be an issue with the change in the field type since the translation is working fine, Please perform the below steps.

Secure a backup of your site
- Deactivate WPML and Advanced Custom fields multilingual plugin ( this won't cause any data loss)
- Try updating the custom field image in the home page

If the issue is still the same then this is something related to ACF. However, Please let me know the results.

Kind regards
Raja

April 4, 2019 at 7:15 am #3532773

sophiaH-2

Yes still same issue I deactivated all WPML plugins but still image not updating

April 4, 2019 at 11:03 am #3534221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Since the issue persists even after WPML is deactivated.
This confirms the issue is not happening due to WPML.

This may be related to the changes you made in the ACF image field from id to array.

Please check with ACF support, they would give you a definite solution.

Wish you the best.

Kind regards
Raja