This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Andreas W. 6 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
March 22, 2019 at 4:47 pm #3442521

Becky

I am trying to: edit a post with several field groups

Link to a page where the issue can be seen:

I expected to see:One set of fields

Instead, I got:It's in the dashboard only, but now I have field groups showing up 4 times!

I don't need the field groups translated, just the content of the fields. What is going on here? This showed up with the updates I did at the beginning of the month. When I set one field group to Not translate, I then get multiples of 4 (we are using 4 languages) in the field groups as well.

I did find these articles on your site, but I’m still very confused and don't know what to do here.
https://wpml.org/errata/acf-duplication-issue-field-types/
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

I can give you admin access, but I'll need your IP first to get past the firewall.

Please advise. Thanks,Becky

March 25, 2019 at 9:44 am #3451149

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you some other means (without IP address block) to grant us access to the site? Personally I don't have static IP address and it may change during the work. We could, however, try with creating a site clone using Duplicator and then testing locally, let me know if this would be an option for you (or I can see if we have someone that use static IP).

Regards,
Bruno Kos

March 25, 2019 at 4:19 pm #3456159

Becky

Sorry, you really need a static IP and I really need this to get fixed. The site is very large and a complete pain to get a clone working. I can send you a backupbuddy archive file, but it’s close to 1.5gb. Please assign this to someone who does have a static IP or let me know if you can make this work. This has been an issue for over a week now, and it’s quite disconcerting for editors. I started this ticket with ACF, and they concur that this is a WPML issue and I’m a bit surprised that I’m the only one reporting it. Please get back to me ASAP.
Thanks,
Becky

March 26, 2019 at 9:47 am #3461097

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Becky,

1.5. GB is not a problem - I can download this BackupBuddy package and see if I can deploy it on my localhost. I've set your next reply to private so that you can put links inside (or you can let me know how I can I download it).

Regards,
Bruno Kos

March 26, 2019 at 3:52 pm #3464271

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Becky,

Since you are in USA-based time zone, I asked my colleagues who are more in line with those time zones to assist promptly, so Andreas will take over this ticket.

Regards,
Bruno Kos

March 26, 2019 at 11:39 pm #3466953

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience while I have downloaded the backup of your site.

Sadly, I do not have a version of BackupBuddy available and I was not able to locate a backup file of your database on the archive. Could you please provide me a export file from your complete database (sql, csv, etc.) for me in order to import it on the local test environment?

You next message is set to private by default. You may further use a Dropbox link or similar services to provide the file.

Thank you!

Kind regards
Andreas

March 27, 2019 at 4:05 pm #3473401

Becky

Hi Andreas,

You must understand how frustrating this is for me, I submitted this ticket 5 days ago and so far we have gotten nowhere. Here's a link to the latest version of BackupBuddy. hidden link

I can also set you up with access, but you need a stable IP, so I can white list it and you can get to the admin. The last support person couldn't do that - and now this is getting ridiculous. 5 days in, I still have no idea what's going on....

March 27, 2019 at 9:09 pm #3475793

Becky

The normal way to migrate a site with BackupBuddy - create a new db, place the .zip file and importbuddy.php into a directory and run the import buddy script. The script will then expand the files and map things to the new database.

The importbuddy file and the actual database are in wp-content>uploads>backupbuddy_temp>wyqoi6huph
If you want to do it more manually, that's where things are.

March 28, 2019 at 2:54 pm #3482759

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am really sorry for delay but there are problems by migrating your site on localhost. The migration is still running since yesterday afternoon and importing the tables of the database is taking way longer than expected.

I would kindly like to aks you to provide access to your site in order to obtain a Duplicator Package in case the migration fails.

Further, I will be sending you a private message within some minutes with information to migrate your website to a test server on Cloudways.

I am sorry about the inconveniences in regards to waiting time. Please leave me a short message once the migration to Cloudways has been completed.

Kind regards
Andreas

March 28, 2019 at 3:22 pm #3483089

Becky

I warned you guys about this, this site is a bear. BUT, you or no one else can work for one day on the same IP?? Really? If I can whitelist your IP, then you can just login to the site and see what's going on. I'm not going to do anything with Cloudways - just give me an IP to whitelist and I'll set up an account so you can login. I can't be the only client with the Sucuri firewall, nor the only one with ACF fields that have gone wild. This is really quite unacceptable. Please let me know.

March 28, 2019 at 3:50 pm #3483423

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just sent you a private message with credentials for migrating your website to our Cloudways test server.

Please leave me a short message once the migration is completed.

Kind regards
Andreas

March 28, 2019 at 4:32 pm #3483905

Becky

Maybe my reply crossed yours and you didn't see my reply. The site I want you to login to is a Staging version, so I'm less concerned with you breaking anything there. If you can just give me an IP, this will be much faster. Please let me know.

March 28, 2019 at 6:44 pm #3485017

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just you a private message with my IP information. The ImportBuddy migration is still running on Step 4 in order to restore the database. I might try to create a Duplicator Package with Duplicator PRO and exclude any Uploads or Backups. This might solve the current issue about the migration.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

March 29, 2019 at 4:11 am #3487529

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience while I was able to migrate a copy of your site with Duplicator PRO.

The provided BackupBuddy migration sadly failed in attempting to migrate the database.

I have to let you know that apart of the Advanced Custom Fields issue I discovered many errors on your site that refer to changes in your custom theme. I would kindly like to advise you to enable the wp-debug feature and revise the debug.log inside of your wp-content folder.

In order to activate the wp-debug feature please edit/add these both lines in your wp-config.php file:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);

After that visit your site´s back end and front end while wp-debug fetches the respective errors found. They can be obtain the debug.log file which you find in your wp-content folder.

One of these errors refers to:
PHP Warning: Use of undefined constant ICL_LANGUAGE_CODE - assumed 'ICL_LANGUAGE_CODE' (this will throw an Error in a future version of PHP) in C:\wamp64\www\lafeber\wp-content\themes\VETSITE2\functions.php on line 99

Please check this and replace ICL_LANGUAGE_CODE with 'wpml_current_language'

This should solve this error. More information here:
https://wpml.org/forums/topic/php-error-ificl_language_codeen/
https://wpml.org/wpml-hook/wpml_current_language/

There are more errors referring to the functions.php and other files of your custom theme. Please take note that our policy does not cover any support in this case and I will need to ask you to contact a professional developer.
You can find experienced developers that have knowledge of WP and WPML here:
https://wpml.org/contractors/
https://wpml.org/purchase/support-policy/

I further encountered some database errors that are not realted with WPML:
WordPress database error: [Table 'lefeber.wp_swp_log' doesn't exist]
SELECT wp_swp_log.query, count(wp_swp_log.query) AS searchcount, md5(wp_swp_log.query) AS hash FROM wp_swp_log WHERE tstamp > DATE_SUB(NOW(), INTERVAL 1 DAY) AND wp_swp_log.event = 'search' AND wp_swp_log.engine = 'default' AND wp_swp_log.query <> '' AND wp_swp_log.hits >= 1 GROUP BY wp_swp_log.query ORDER BY searchcount DESC LIMIT 10

WordPress database error: [Table 'lefeber.wp_swp_log' doesn't exist]
SELECT wp_swp_log.query, count(wp_swp_log.query) AS searchcount, md5(wp_swp_log.query) AS hash FROM wp_swp_log WHERE tstamp > DATE_SUB(NOW(), INTERVAL 30 DAY) AND wp_swp_log.event = 'search' AND wp_swp_log.engine = 'default' AND wp_swp_log.query <> '' AND wp_swp_log.hits >= 1 GROUP BY wp_swp_log.query ORDER BY searchcount DESC LIMIT 10

I had issues with connecting to the site at first place for which I had to manually disable the plugins folder. Afterwards there were many issues when trying to reactivate plugins. Most likely this is caused due to compatibility issue.

For further investigation about the ACF issue I changed to the default theme TwentyNineteen.

I also experienced very long loading times which for I would kindly advise you the following:

Could you please increase your PHP Memory Limit to 1024 and the WP Memory limit to 512M?
Your current values are:

MemoryLimit 256M
WP Memory Limit 256M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '512M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

The PHP Memory Limit should always be higher than the WP Memory Limit. You can change the value inside of the php.ini of your currently used PHP Version 7.1.27.

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.
As you are using many plugins and a custom theme I would advise you to set the limits way higher.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000 or even 5000.
You can find the php.ini file on your server. In case of any doubt please contact your hosting provides and ask for assistance.

Now about the actual ACF issue I will need to ask you kindly to have some patience, as I have spent various extra hours for today and I will be working on it right in the morning.

I hope for your understanding.

In attachment the debug.log from my debugging session so far.

hidden link

Kind regard
Andreas

March 29, 2019 at 8:30 pm #3494809

Becky

Thank you for all of this information. This site was built over 4 years ago, when all of that ICL code worked. I will look at all of this and do my best to clean things up.

In the meantime, do please let me know about the duplicated fields. Thank you for your time.
Becky