This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
June 5, 2019 at 8:28 am

ianM-17

I am trying to: Translate a page using the new translation method and have all the ACF powered content appear after I save the translation.

Link to a page where the issue can be seen: hidden link

I expected to see: Where you have the gray band there should be a background image that is powered by and ACF field. The two shortcodes [vendors hierarchy] and [awards] should show content that is powered by ACF fields on the page.

Instead, I got: The shortcodes are not rendering the ACF field content neither is the background image showing on the gray block.

If after clicking save and close on the translation you can then visit the page you've just translated, click "edit anyway" and then click publish on the page, it is only at this point that you see the ACF fields appearing.

I recall the old way WPML worked and when you clicked translate in the page right sidebar it would then prompt you that once the page was published it would copy over all the ACF fields that you had set up to copy using the custom fields section of the multilingual content setup panel.

Is there a way for the copying of ACF fields to happen during the new translation process as we are using a third party translator who export xml translation files through the WPML translation management and then re import them after they have finished with them. Due to the fact that the posts and pages don't automatically publish after reimport it means we are going to have to go through every page that has been reimported and manually publish every page.

June 5, 2019 at 4:31 pm #3962701

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked things on your site.

You wrote: "If after clicking save and close on the translation you can then visit the page you've just translated, click "edit anyway" and then click publish on the page, it is only at this point that you see the ACF fields appearing."
I've tried, and I can confirm that I can see that this fixes the issue. But I need to ask you a few questions, please.

1. The following URL of the translated page that you gave me is different in the structure of the original English page.
The nl-BE URL that you gave me:
hidden link

The original English URL:
hidden link

Can you please tell me why they are different?
It seems that a parent page is missing in the translation and I'm not sure what is /specialisations/, but it is also missing on the translation.

2. You wrote: "Translate a page using the new translation method..."
I'm not sure what method do you mean.
Can you please specify which new method is that?

3. You are using the Lingo24 Translation Service.
Can you please confirm this?

4. I can see that WordPress is not updated to its latest version. WPML and its add-ons are also slightly not updated. The same goes for the ACF Pro plugin.
Can you please update everything and see if the issue persists?
Updating everything is the first and most important debugging step, and anyhow recommended.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

I look forward to your reply!

Itamar.

June 7, 2019 at 8:35 am #3974807

ianM-17

Hi Itamar,

In answer to your questions -

1. You are correct in your assumption of /specialisations/ being a parent page. I haven't translated this in this test and I don't see how it would cause the issue that we are seeing.

2. This is the new method (see attached) before you just added your translations on the page rather than in these meta boxes.

3. Yes we are using Lingo24 as our translators.

4. I've updated all plugins and WordPress now.

Thank you 🙂

June 10, 2019 at 3:10 pm #3988435

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for following my suggestions and answering my questions.

I'm still not sure how you are using the ACF fields on your site. Mainly I'm still not certain how you display them with shortcodes. And which field groups are being used. If possible, then I would like to create a test page and replicate this issue.
Can you please explain to me a step by step process how I can replicate this issue on your site?

Thanks,
Itamar.

June 11, 2019 at 8:41 am #3993335

ianM-17

Hi Itamar,

Sure thing here are the steps to recreate the issue -

1. login to hidden link using the details attached to the initial ticket.

2. Visit the english page specialisations/practice-areas/advanced-networking in the backend hidden link

3. In the right hand language pane click the plus icon to create a translation for Belgium (FR)

4. Using the translation meta boxes and click "Copy all fields from original" to duplicate all content from English to Belgium French. Check the "translation complete" checkbox and then click "Save and close" to close the page translation page.

5. Visit the English page on the frontend and then use the language switcher to switch to the page you've just translated into Belgium French.

6. You will see that no ACF field or Shortcodes have been copied over.

7. Visit the Belgium French page in the WordPress backend and then when you are prompted by the WPML modal click "edit anyway"

8. Click the update button and then visit the frontend of the page.

9. You will then see all the shortcodes and ACF fields magically appear.

June 11, 2019 at 7:06 pm #3998135

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the detailed steps.

I have followed those steps, but I see partial results. The background images on the grey section do show. But the [vendors hierarchy] and [awards] shortcodes are not showing the 'Award-winning recognition' items and the 'Advanced Networking Practice
Core & Complementary Vendors'.

I assumed that the issue was settings of the system fields as described in our documentation here.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields
I could see that the _nuv_secondary_content_area and the _nuv_tertiary_content_area system fields were not set as their parent fields nuv_tertiary_content_area and nuv_secondary_content_area. Please see the attached screenshot. So I've set them to be also 'Translatable,' but it didn't help. Then I tried when they are set to 'Copy,' but it didn't help either.
Have I missed a step?
Can you make the shortcodes show their content?

Note: For tests, I needed to translate two other languages pages (Belgium NL and Switzerland DE).

So it seems that we have here two issues.
1. The background images of sections only get copied to the translation with the WordPress editor.
2. Shortcodes on custom fields are not showing the intended content on translations.

I'm sorry because I think that I was not clear enough when I asked you the steps on how to replicate the issue. I want now to set up a test site and see if I can replicate the issue on a clean WordPress installation. I'm going to install a new site with WPML and ACF. What I need from you, please is how to create the shortcodes that you are using and configure ACF to work with the shortcodes.

Since your theme and other plugins might be involved in this particular set, maybe it would be easier if you set everything on a test site. For this, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install only the required plugins and theme see if the issue is replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site. You do not need to configure all the language. Only configure one default language and another language. Please also make sure that you are installing the latest version of the theme plugins.

Thanks,
Itamar.

June 14, 2019 at 8:24 am #4019233

ianM-17

Hi Itamar,

Would it be as easy for us to clone our site onto a new WPEngine install for you to test on rather than copying all required files over to the test install you've set up?

June 16, 2019 at 12:25 pm #4030411

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Since I suspect that this is a compatibility issue with ACFML and your theme (and possibly other required plugins for your theme) it is necessary to replicate this issue on a clean WordPress installation, this is the correct procedure before escalating compatibility issues to our compatibility team. On the test site that I've created, you only need to install your theme (and any add-on plugins). You can only configure things that are relevant to the issue. You do not need to replicate the complete install that you have on your live site.

Thanks,
Itamar.

June 20, 2019 at 8:26 am #4057585

ianM-17

Thanks Itamar I'll go right ahead and do that.

June 20, 2019 at 9:00 am #4057795

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks, I'll wait for your reply when things are set up.

June 20, 2019 at 10:03 am #4058643

ianM-17

Hey Itamar,

Whilst going through the WPML setup process specifically creating the one language the site just hung and now has the message "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions."

So I'm a bit stuck now!

June 20, 2019 at 3:45 pm #4061131

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see this problem... I wonder what happened. In any case, here is a new sandbox site. I've already configured it to have English as the default language and French as the second language.

hidden link

Regards,
Itamar.

June 24, 2019 at 8:28 am #4075471

ianM-17

Hi Itamar

I uploaded the theme and the exact same issue has happened and now the site is stuck once more 🙁

June 26, 2019 at 11:20 am #4091915

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

OK, I'm not sure why the test site is breaking when you upload your theme. Let's, please continue in another path.
Could you please create a clone of your site on your server, as you suggested here before, and let me have access to this site?

Alternatively, I can also create for you a test server on our our server, and you can migrate your site to our server. If you want to go with this option, please let me know.

I'm enabling a private message for the next reply.

Regards,
Itamar.

The topic ‘[Closed] ACF fields do not show after translation until page manually published’ is closed to new replies.