This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by royE 3 years, 5 months ago.

Assigned support staff: Bruno.

Author Posts
October 18, 2015 at 4:09 pm #727436

royE

I am trying to: I am trying to update ACF field labels.

URL of (my) website where problem appears: hidden link (password protected).

I expected to see: different label for each language.

Instead, I got: Every time I update a label on ACF in one language, it updates the other language.
I have read this guide (https://wpml.org/documentation/theme-compatibility/setting-wpml-advanced-custom-fields/), but I can't understand why this happens

Thanks

October 19, 2015 at 7:58 pm #728353

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Roy,

You clicked on the button to translate independently? https://wpml.org/documentation/theme-compatibility/setting-wpml-advanced-custom-fields/#attachment_552902

The post content / custom field is overwritten when a post is duplicated. That is, you need to click at this button to translate the content of the labels of the ACF.

Thank you.

October 19, 2015 at 10:17 pm #728402

royE

Thank you for your response.
I am aware of that, but that is not the issue, as you can see in the screenshot.
What else can make one language overwrite that other?
Thank you

October 20, 2015 at 5:11 pm #729245

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

In the "Multilingual Content Setup" option, at the end of the page, if you have selected the "Copy" option, the custom field options are copied to the secondary languages. I will attach a picture for you to see.

** Note: on the screenshot I posted, the custom field is named "field_56216095d1562". In your installation this can have another string "field_{any-string-here}".

If the option is set to "Copy", you can select the "Don't translate" or "Translate".

Please let me know if this option is selected and that changing it, the problem is solved.

Thank you.

October 21, 2015 at 9:06 am #729626

royE

Thank you very for your assistance,
but the problem still persists, and the fields override each other.
The multilingual setup is set to "Don't Translate".

October 21, 2015 at 12:13 pm #729829

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

******* Please let me know exactly what steps should I follow to see the problem.

**** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 27, 2015 at 6:47 pm #733980

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Roy,

Thank you for credentials.

As a test I updated one slug and it was not synchronized in the second language. I will attach a picture for you to see "ingredients-2" on the English and "ingredients" on the Hebrew, so the slug has not been synchronized.

I must follow some extra step to see the problem?

Thank you.

October 28, 2015 at 10:14 pm #735063

royE

Hi there
Thank you for your patience.
It works on the Dev site, but I don't understand how to solve the problem on the Live site.
If I change the slug in one language, it changes the slug of the other language.
Please explain how you solved it.
Thanks.

October 29, 2015 at 8:18 pm #735876

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Roy,

In fact I did nothing. I just followed the steps you had mentioned to try to replicate the problem and the problem did not happen.

The test environment before, was with the same site of the problem in production?

Thank you.

October 31, 2015 at 11:16 am #736860

royE

Please try to fix it on the live site:
hidden link
roy
Cuxj24PLEzXs1p!DdUj2H&Fq

Custom Fields is here:
hidden link

Thank you very much

October 31, 2015 at 12:06 pm #736871

royE

Issue is NOT resolved.
Also, I've posted the password out in the open...
The username and password have been changed, but please delete my last comment.