This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bigul 6 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 28, 2019 at 8:49 am

jamesM-38

Hi,

I originally built/setup WPML so that English was the default language and French the secondary language. My client has asked me to change this so French is the default language however now when we go into the WP admin dashboard we can't access any ACF fields in either language.

I have to refresh the editing screen several times before they show up in English which surely can't be correct?

Any help/advice would be greatly appreciated.

Thanks,

Jams

March 28, 2019 at 1:08 pm #3481213

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the translation settings of the *Home Content French* field Group. The fields are set as *Don't translate* now and the Homepage is a translation of English now.

Please choose *Translate* option for those two ACF fields. Then check you are getting the expected result or not.

If you are still having the issues, please tries the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

March 29, 2019 at 9:13 am #3489307

jamesM-38

Hi Bigul,

Thanks for the reply, the issue is with the ACF fields for the "Property" post types (not pages).

I've followed the steps in your email below but unfortunately the problem is still there.

I've just had a look in the "Properties" section and I can't get the ACF fields to show up at all for either language now even after refreshing a few times?

The site uses a CDN, I'm not sure if that could be causing this issue?

Kind Regards,

James

March 29, 2019 at 6:34 pm #3493901

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the updates. This may be happening because of the Property Custom Fields Groups are not translated to French. Please try the following steps after a backup and let me know your feedback.

1) Set *Copy* as the translation preference for *property_gallery* field
2) Please duplicate *Property Gallery* Field Group to French
3) Create a new Property post in French or English
4) Make sure the field is showing for you or not

Please check the attached images for more details.

--
Thanks!

Bigul

April 2, 2019 at 4:15 pm #3519071

jamesM-38

Okay thanks, I'll give that a go and let you know if there's anything else.

Kind Regards,

James

April 3, 2019 at 8:20 am #3523511

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the updates. Take your own time. We will wait for your feedback.

--
Thanks!

Bigul

April 5, 2019 at 9:51 am #3542735

jamesM-38

Hi,

Unfortunately I'm still having problems with this, what my client would like is that all the ACF fields only show up for the French language apart from the my default title, default content area and a ACF field for summary.

I've changed over all the ACF fields so that they're now associated with the French language (not English like they were originally) and set them to copy the enter values across (see screenshot) however when I go to edit a property in French nothing shows up?

Kind Regards,

James

April 5, 2019 at 12:26 pm #3544035

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi James,

Thank you for the updates. Please create a new Property Post and check the issue is existing or not.

Also please share with me the WordPress debug.log (not WPML debug information) for tracking the issue. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] ACF Fields No Longer Showing Up For Either Language in WP Admin’ is closed to new replies.