This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by nigelH-8 2 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 15, 2019 at 3:31 pm #4402145

nigelH-8

I am trying to: set up language pages these are to be translated manually

Link to a page where the issue can be seen: sorry it's currently local dev

I expected to see: to see ACF fields on duplicated pages

Instead, I got: no ACF fields on duplicated pages

August 16, 2019 at 12:17 am #4403845

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It most likely happens due your translation preferences for the custom fields, before a more detailed investigation, can you please confirm if you followed our instructions on how to proper setup ACF with WPML at: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/? Please, let me know if it helps, have a nice day.

August 16, 2019 at 7:16 am #4405055

nigelH-8

Thanks Marcos,

Yes I followed these steps, the only way I am able to get the fields to appear in the editor is to duplicate the field group for each language. I can see the fields in the System Fields panel.

August 16, 2019 at 3:48 pm #4407473

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I've just tested Advanced Custom Fields + WPML Advanced Custom Fields Multilingual and it works properly in a clean installation. In other words the duplicated page shows the fields group properly. Please, review these settings in your particular case:

1 - Make sure the 'acf-field-group' is set as 'Not translatable' in your WordPress Dashboard > WPML > Settings > Post Types Translation

2 - Make sure your fields are set as 'copy' or 'copy once' in the field translation preferences from your WordPress Dashboard > Custom Fields > Fields Groups

3 - As a test purpose add a new page, duplicate it and confirm if you see the fields groups in the translated page.

You can confirm these settings ans compare with yours at: hidden link it is a one click login, so you can click, get logged and see the ACF settings of my tests. You can see the fields working properly in the 'Sample Page'.

Please, let me know if it helps. Have a nice day.

August 18, 2019 at 10:11 am #4411879

nigelH-8

Hello Marcos,

That appears to have worked. One thing I have noticed, if I delete the translated page and duplicate the English page again it does not copy the value information over specifically for radio button and images. Will I need to create a new page to have these copied correctly?

August 19, 2019 at 9:47 pm #4419327

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case you would need to make sure these fields has the correct translation preference set as 'copy' or 'copy once' in your fields settings and after that you would need to make a minor editing in the default language page and update it in order to 'force' those fields to have their values copied to the translated page. Please, let me know if it makes sense or if you need any additional assistance and clarifications, have a nice day.

August 20, 2019 at 7:55 am #4421219

nigelH-8

Thank you Marcos yes that makes sense.

August 20, 2019 at 7:56 am #4421221

nigelH-8

My issue is resolved now. Thank you!