This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by Carlos Rojas 9 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 10, 2018 at 8:43 am #2719202

rogierK-3

We have a multilingual site on nutrisuin.nl, build with beaver builder, acf and wpml.
There's a long history with problems translating this site, we finally settled on not using the translation editor, as it causes all kinds of issues, which we can't solve, even after numerous supportrequests with the wpml support team.

This summer we decided to rebuild the website from scratch in the native language (Dutch) eliminate all poluted code in the hope we can now succesfully build a multilingual site in which we can use the translation editor. We set up test.nutrisuin.nl for this.

We first build the site using beaver builder themer layouts and ACF. After finishing the site, we installed WPML and started with translating the homepage with the translation editor. We didn't see the page translated on the frontend however. When switching to "manual translation" we noticed that, although the translation is 100% complete according to the translation editor, the acf fields are not present in the wordpress page editor in the translated page.

September 11, 2018 at 4:06 pm #2724583

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Since the form fields are not showing up on the translated page when using manual translation, I suspect that there is something wrong with the way the fields were translated. Please review this documentation and follow it step by step: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/.

Then update the original and let me know if you see the fields on the manual translation.

September 12, 2018 at 7:15 am #2726333

rogierK-3

Hi Lauren,
Thanks for your reply. I allready followed this instructions closely when installing WPML and translating the page, so I'm lost.

September 12, 2018 at 2:43 pm #2727975

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 12, 2018 at 8:01 pm #2728895

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket because our colleague Lauren is off today.

Today we released a new version of WPML plugins, I kindly ask you to update all outdated plugins to their latest version and double check if the issue persists.

Looking forward to your answer.
Best regards,
Carlos

September 13, 2018 at 11:56 am #2731368

rogierK-3

Hello Carlos,

No, the updates did not make a difference, we also did a test on a fresh installation and could reproduce this problem.

Field groups in ACF which are assigned to a specific page can be translated in the translation manager, but the fields are not available in our layout. When we switch to manual translation no ACF fields seem to appear in the translation although in the default language the are present.

Are we missing a setting?

Hope you can help because we followed every guideline without success..

Thanks,
Rogier

September 13, 2018 at 8:31 pm #2732953

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Rogier,

In this case I would like to ask you to follow this steps:
- Go to WPML -> Settings -> Custom Fields Translation -> Set to 'Translate' the fields that doesn't appear in the Translation Editor.

Note: I can't change the language in the user's profile. If the issue persists after the steps above I kindly ask you to set the admin language to English or Spanish 🙂

Best regards,
Carlos

September 14, 2018 at 6:57 am #2734166

rogierK-3

Hi Lauren, Carlos,
Thanks for your reply.
The steps you suggest, we followed long before we posted our support request.
Did you read the support thread?

September 14, 2018 at 4:24 pm #2736155

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Rogier,

I'm sorry for the misunderstading. I'm having a hard time with the backend language as I only speak Spanish and English.

I suspect that the cause of this issue is that the ACF groups aren't set to translate nor translated, however the credentials shared doesn't have admin permissions which doesn't allow me to take a deeper look at this site and all the configuration.

I would need a sites snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this porpoise.

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions: hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Looking forward to your answer.
Best regards,
Carlos

September 17, 2018 at 6:52 pm #2742315

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Go to WPML -> Settings -> Port Types Translations -> Make sure that 'Field Groups (acf-field-group)' is set to 'Translatable - only show translated items' or 'Translatable - use translation if available or fallback to default language' -> Save changes.
- Go to Custom Fields -> Fields Groups -> Edit 'Homepage' field group -> Translate it to the secundary languages -> Save the changes -> Once the Homepage field group is translated change the language in the admin menu and use the option 'Overwrite with NL content' if necessary -> Save the changes.

Could you tell me if the issue is solved?

Best regards,
Carlos

September 19, 2018 at 8:15 am #2747715

rogierK-3

Hi Carlos,
This helps indeed, I see the custom fields in the englisch translation now...
At the same time it's very confusing:

1. The WPML documentation states that it's only necesary to translate field groups when you need to translate the ACF user interface (https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/) We got this confirmed several times from WPML, also there are numerous forumthreads about this issue. But supportpeople from WPML still keep suggesting this solution to their clients. What are we missing here?

2. ACF states in their manual for WPML that you do have to translate the fieldgroups (hidden link). Why does the method ACF describes differ from the procedure from WPML?

3. We allready tried translating the field groups before we contacted you, it had no effect! It seems that the procedure of translating field groups is not bullet-proof and a special workflow needed. Is this the case?

4. We can use the translation manager without translating the fieldgroups. So if this works, why don't the fields show up at manual translation?

Please help, we need a solid solution on which we can build on. It's hard to stay motivated when we repeatedly need to adress this issue.

September 19, 2018 at 5:09 pm #2749605

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I will consult our specialists about this subject and I will get back to you as soon as I have an answer.

Best regards,
Carlos

September 21, 2018 at 2:45 pm #2755587

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I have escalated this questions to our documentation team. Our specialists there will take a deeper look at this questions and I will get back to you as soon as I have an answer.

Best regards,
Carlos

September 25, 2018 at 2:31 pm #2764258

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Rogier,

I.- This is the answers I got from our documentation team and our specialists in ACF:

1. Yes, this is true. Better is to not translate field group.

2. ACF has old documentation. They tried to support wpml long time ago and they gave up leaving documentation. It is irrelevant and obsolete now, created long time before I created ACFML.

3. Yes, translating field group is not bullet proof, this is why I discourage anyone from doing it 🙂

4. No comment from me as this just repeats main question.

And having this main question why they don't see fields under translated post/page here I my guesses:

- they still has set Field Group post type as translatable. When I say "don't translate" I mean don't set this post type (field group is just a post type) as translatable and don't even try to translate 🙂

- they set display rule for field group to be like "display field group when page id/page template is set to {something}" and the page in secondary language doesn't meet this rule.

II.- In order to reproduce this issue in a fresh new install I have created a test site from scratch, I have setup WPML and installed ACFML. I would like to ask you to install ACF, set it up and reproduce the issue. This way I will be able to compare both sites (test and production) and if necessary, escalate to our compatibility team.

To access the test site just follow this link: hidden link

Looking forward to your answer.
Best regards,
Carlos

September 26, 2018 at 7:43 am #2766228

rogierK-3

Hi Carlos,
Thanks for your reply.
Before I setup another test site (we allready reproduced this issue multiple times on a new testsite), I'd like to respond on your reply:

In contrast to you, your team member says we don't need to translate the fieldgroup. We allready knew this before posting this support request. We only set this options, because you asked us to.

One remark from your team member interested me:
"...they set display rule for field group to be like "display field group when page id/page template is set to {something}" and the page in secondary language doesn't meet this rule."

In reaction to this remark I tried the following:
- deleted the existing translations of the fieldgroups
- set the field groups as "don't translate" in the wpml settings menu
- opened the field group "homepage" and tried to set the display rule to add the translation of the "home" page

The last action however is not possible. I can only add the original language pages, not the translations of this page. So in result, the acf fields disappear from the translations.

I'm sorry to say, but the confusion only gets bigger:
Carlos says: please translate the field groups ... and the field groups appear on the translated version of the page.
Your team member says: don't translate the fieldgroups! ... and the field groups again disappear on the translated version of the page.
However your team member tends to disagree with you, your solution seems to work and his doesn't.