Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 1 voice.

Last updated by patrizio-romanoD 2 years, 6 months ago.

Author Posts
May 29, 2017 at 3:17 pm #1286644

patrizio-romanoD

I am trying to:

As I made for a long time and successfully on another project, I'm trying to translate indipendently many ACF custom fields, from italian (main language) to english.
All the Custom Fields are used on pages and on custom post types I had set up.
I followed your guide here:
https://wpml.org/documentation/plugins-compatibility/translate-sites-built-with-acf/

and double checked if all the fields have option set to "translate".

URL of (my) website where problem appears:

mdf.patriziord.it
(You have to get into the folder with credentials I can provide privately).

I expected to see:

on the custom post type "Agents"
after clicking "duplicate", editing the translation, "translate indipendently"
after checking that all the custom fields multilingual options are set to "translate"
when I update the field "description", and update the post, the fields saves e shows the right content

Instead, I got:

the field keeps showing the content duplicated, no change is saved

Steps to duplicate the issue:

see below on "I expected to see".

Thanks in advance,

Patrizio

May 30, 2017 at 9:01 am #1287106

patrizio-romanoD

Hi,

after some struggle I stumbled upon this "little" ACF configuration missing step, which solved my issue:
hidden link

For anyone who'd find this useful in the same situation, please consider:
- I installed the Advanced Custom Fields Multilingual plugin
- I changed my configuration in WPML -> Translation management -> Multilingual content setup -> Custom posts translation: setting the "Field" option to "do nothing".

This solved my issue.