This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 26, 2019 at 7:03 pm

Jeremy

We are trying to: Update ACF fields on a post (using the Default English Language selection)

Link to a page where the issue can be seen: hidden link

I expected to see: All custom field values updated

Instead, I got: Only 2 custom field values got updated, the rest reverted to the original.

It's only happening on a single post, You can simply try updating the field "First Name" which is currently "Hugh", I attempt to set it to "Hugh1", then hit the UPDATE button, First Name still shows "Hugh".

When I attempt to update values of another post ID (of the same post type) then all values update just fine.

When I de-activate WPML, all values updating just fine across all psots, so it leads me to believe WPML is blocking the custom fields from getting updated.

We also tried enabling the latest version of Advanced Custom Fields Multilingual to see if it will help, but it didn't.

FYI: FTP is not available, but we enabled File Editing in WP CONFIG.

Thanks

June 26, 2019 at 9:08 pm #4095179

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Could you tell me if the issue persists if you re-create the post?

2.- Please update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.

Note: Please don't forget to create a full backup of the site before making any change.

Kind regards,
Carlos

June 26, 2019 at 9:24 pm #4095195

Jeremy

Hi Carlos,

Thanks for the response.

1. The issue doesn't persist if you create a new post
2. I de-activated ALL plugins except for WPML and ACF, They are at the latest version.
3. Everything is backed up, it's a staging site, so feel free to do anything to it.

Correction for the Admin URL, it is: hidden link

Thank you

June 26, 2019 at 9:30 pm #4095213

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

If the issue doesn't persists if you re-create the issue then it is possible that the post had some issue in the database entry. In this case I recommend you to substitute the post for a new one and confirm that the issue disappeared.

Regards,
Carlos

June 26, 2019 at 9:56 pm #4095237

Jeremy

My worry is that there might be more posts with this issue.

I want to get to the source of the problem and fix it instead of coming up with a temporary workaround.

Also, what happens when additional posts start breaking, do we need to keep re-creating them?

I rather fix the source of the problem.

Thanks

June 27, 2019 at 11:01 am #4099425

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I understand your concern.

I took a deeper look at the site and updated all outdated plugins except for WPML plugins. Before I continue I need to ask you to update WPML plugins -you might need to do it manually- also contact your hosting provider and ask them to update the PHP version to meet our minimum requirements: https://wpml.org/home/minimum-requirements/

Please let me know when this is done so I can continue debugging this issue.
Best regards,
Carlos

June 27, 2019 at 4:11 pm #4101519

Jeremy

Hi Carlos,

- WPML requirements state PHP 5.6 which is what we're using
- I went ahead and updated all WPML modules to the latest version

Thank you again

June 28, 2019 at 11:59 am #4107151

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I think I have found the cause of the issue. I double checked the post and realize that you can make the changes in French, because this information was originally set in French and doing so the value (I tested with First Name field) gets updated in English too.

After checking the settings for the custom fields I can see that most of them are set to be copied, and that's why they are behaving this way, which is correct. To change this behavior please follow this steps:
- Edit the post -> Go to Multilingual Content Setup section -> Click on 'Show system fields' -> Set the custom fields (please noticed that there are 2 custom fields for each value) to 'Translate' and save the changes.

For example:
- To set the 'First Name' to Translate you need to set it for 'first_name
ACF field name: First Name ACF field type: text' and for '_first_name'

Could you confirm that the issue is solved?

Regards,
Carlos