This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm unable translate my ACF fields that are set in PHP, although the do show up as custom fields and i've set them to translatable, they do not show up in the translation editor.

Solution: To solve this issue I would like to ask you to follow this steps: - Edit the front page in the default language -> Scroll down to the Multilingual Content Setup section -> Click on 'Show system fields' link -> Set to 'Translate' to all fields with the prefixs 'vo_' and '_vo_' -> Save the changes -> Make a small change in any of the content of the page -> Save the page -> Update the translation

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 15, 2019 at 12:50 pm #4211097

paulV-7

I'm unable translate my ACF fields that are set in PHP, although the do show up as custom fields and i've set them to translatable, they do not show up in the translation editor.

I've followed this guide: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Plugin versions are the newest.

Are ACF fields set in PHP incompatible? or does it require another action to get working?

July 15, 2019 at 3:10 pm #4212651

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

This way I will have more information about the site that might help me to better understand the issue.

Kind regards,
Carlos

July 16, 2019 at 7:08 am #4216825

paulV-7

Here you go

July 16, 2019 at 10:12 am #4218821

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you very much for your message.

1.- Please describe step by step how to reproduce the issue.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 16, 2019 at 2:56 pm #4221429

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Could you provide a link where I can see the custom fields?

Regards,
Carlos

July 16, 2019 at 3:48 pm #4222013

paulV-7

Hi Carlos,

Every page will work as all of the pages were built with acf fields set in php.
Such as the homepage: hidden link

Regards,
Rik

July 16, 2019 at 10:28 pm #4224319

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Rik,
Thank you very much for your message.

I visited the site again and I can see the custom fields set to 'Translate' appearing in the Advance Translation Editor. However I can see that most of the Custom Fields are set to 'Not translate'.

To solve this issue I would like to ask you to follow this steps:
- Edit the front page in the default language -> Scroll down to the Multilingual Content Setup section -> Click on 'Show system fields' link -> Set to 'Translate' to all fields with the prefixs 'vo_' and '_vo_' -> Save the changes -> Make a small change in any of the content of the page -> Save the page -> Update the translation

Could you confirm that the issue is solved?

Regards,
Carlos

July 17, 2019 at 7:17 am #4226521

paulV-7

Hi Carlos,

This is strange, they do show up now! I tried this on my local installation, didn't work. Maybe because it's a local installation, however this is all I needed, perfect thanks!

July 17, 2019 at 10:27 am #4228683

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos