This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by brianG-6 2 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 16, 2019 at 2:09 pm #4220881

brianG-6

Hello,

I need to translate the labels on my frontend forms. I followed these instructions, but the labels remain in english on my frontend form: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translating-acf-user-interface. Any suggestions?

July 16, 2019 at 5:59 pm #4223075

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please let me know where can i see the labels in the front end so i can get a better idea of the current issue

also If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

July 19, 2019 at 4:04 am #4243781

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details

unfortunately i was not able to access the site , if possible please review the password. i have re enabled the private field reply

July 19, 2019 at 12:54 pm #4246563

brianG-6

Hm, I just reset it to the same. Please try again. Thanks!

July 21, 2019 at 8:08 pm #4252937

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

how are you creating the form for this page ? hidden link.

i can see that you have set a template on the page called "Request Training" .

i also noticed that you have "enable_for
ACF field name: Enable For ACF field type: checkbox" set to "not translatable "

=> https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

July 22, 2019 at 4:47 pm #4259987

brianG-6

I figured it out, I needed to add wpml_object_id around the field group ID. I was creating the form using acf_form: hidden link. Thanks!