This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 19, 2019 at 11:46 am #3645487

antoineV-14

I am trying to translate the options page with ACF.

All was good but after i updated the plugin firstly my all translations with field for the options page were gone/overwritten with english and now when i try to update the translation language which is arabic in my case it is overwriting the english one.

Please help.
Thanks

April 22, 2019 at 4:36 am #3653899

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be happy to assist you further on this issue.

Does the issue is happening after updating to version 1.2?

Could you please go to WPML->String Translation, search for the string and translate it? Does this method work?

Look forward to your reply.

Thanks

April 22, 2019 at 3:46 pm #3656881

antoineV-14

Hello,

Yes issue happened after i updated the plugin.

I don't need the string translation. It is ACF Options page where i have many fields with tabs.

Please advise asap as i need to go Live with the website and this issue is stopping me.

Thanks

April 23, 2019 at 6:52 am #3659811

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Translating the ACF options page using the language switcher was creating issues and to address this issue our ACF compatibility team introduced a way to translate those options using string translations, you can see the following entry on the changelog of ACFML 1.2.

Fixed the translating ACF Options page (it can now be done using WPML String Translation)

Being so, from the latest version of ACF, the options page are translated using String Translations, so could you please enable the string translation and try it once?

Look forward to your reply.

Thanks

April 23, 2019 at 1:43 pm #3664425

antoineV-14

I installed the String Translation & updated the Multilingual CMS Plugin (was showing there is update) and it is even worse now.

When now i update the general settings page i get errors

Warning: mysqli_real_escape_string() expects parameter 2 to be string, array given in /home/maltablo/public_html/wp-includes/wp-db.php on line 1172
Warning: Cannot modify header information - headers already sent by (output started at /home/maltablo/public_html/wp-includes/wp-db.php:1172) in /home/maltablo/public_html/wp-includes/pluggable.php on line 1251

What is going on guys? I need to launch this website and the only thing i get is more errors with you.

Can you fix please once for all?
Thank

April 23, 2019 at 2:18 pm #3664579

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry for the inconvenience.

To debug this issue further and quickly, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

April 24, 2019 at 12:53 pm #3673081

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am working on the issue and will respond to you soon.

Thanks

April 25, 2019 at 5:37 am #3678899

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can replicate the issue you are mentioning, but I can see that you are not using the "WPML Translation management" plugin, which is a required plugin to translate ACF.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#requirements-and-installation

Further, since the sites have lots of plugins and you mentioned not to make any changes, I will like to replicate your site on my localhost and perform further debugging, so could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

Also, it would be nice if you can provide a link to the pages where the options are being used.

You can zip these files and upload to google drive later to share it with me.

Enabled the private reply for you.

Look forward to your reply.

Thanks

April 25, 2019 at 3:39 pm #3684027

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps to translate the options:

- Go to General settings page
- Select English as Language from the top-admin bar
- Enter your choices and click save
- Now go to string translation and translate those strings

The strings will be shown properly translated on the front-end.

I have tested this on the provided test site and it works properly.

Note: If you change the language in the options page except (English) and make some changes, the options & Translations will be overridden, so please make sure to make changes only on the English language in the options page.

This issue is currently being debugged so until we have further info on the issue, I request you to use the method as explained above.

Let me know if this helps.

Kind Regards,
Shekhar

April 26, 2019 at 12:58 pm #3690877

antoineV-14

Hello,

Hmm i see,

So i just need to find the string under String translation, as i see no need to use general settings page for now, correct? I just find and translate from String Translation?

Also if i translate now in this way will it be automatically shown in the general settings translated page after your fix? Or i will need to do all the translation again?

Please advise.
Thanks

April 26, 2019 at 1:57 pm #3691153

antoineV-14

Hey one more thing please,

I have a section with ordering items, in translation i need to change the order, how i do that via string translation please?

Thanks

April 29, 2019 at 6:35 am #3700251

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, you should just find the strings under string translation and translate it.

You should use general settings page only to make changes in options for default language, for other languages you should use string translation.

Since all the translation is done from string translation, the language switcher on options page has no meaning at the moment, there is an ongoing development ticket about this issue. You will not need to do all the translation after the fix.

Regarding ordering items, could you please provide a screenshot so I can check and provide feedback quickly?

Look forward to your reply.

Thanks

April 29, 2019 at 6:44 am #3700365

antoineV-14

Hello,

So the section i need to change an order is flexible content field like a repeater for the footer menu items. For the translated language i need to change the order as language is arabic 🙂

Attaching screenshot.
Please advise.
Thanks

April 29, 2019 at 9:02 am #3701419

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry to let you know that it's not possible to order the fields currently.

For further feedback, I have escalated this issue to our 2nd tier supporter.

Our 2nd tier supporter will take a look at this issue. Once they provide any feedback, I will get back to you with that feedback here.

Thanks

May 8, 2019 at 10:59 am #3765753

antoineV-14

Hello,

Any update please?

Thanks

The topic ‘[Closed] ACF general settings translated page is overwriting other language (default)’ is closed to new replies.