Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by nikolayP-6 2 years, 5 months ago.

Assigned support staff: Yvette.

Author Posts
September 5, 2018 at 1:46 pm #2707398

nikolayP-6

Hi.

Are ACF fields with visual WordPress editor compatible with WPML? I only see a one-line field.
I see ACF glue plugin beta 0.9-b version, but it has no description in the changelog.

September 5, 2018 at 11:00 pm #2708909

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @nikolayp-6, welcome to the WPML support Forum!

Yes, ACF is compatible with WPML, but it is necessary to install the glue plugin.

Please take a look at this guide: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

If you need more help just let me know.

All the best,
Diego

September 6, 2018 at 8:38 am #2710016

nikolayP-6

I have it installed (not beta), but the field is on one line instead of full WordPress visual editor. Any suggestions?

September 6, 2018 at 5:57 pm #2711845

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please try the following:
- Go to WPML > Settings
- Scroll down to Custom Fields Translation
- Find the Custom Fields, set them as "Translatable" and save
- Go to the edit screen of the page (default language), do a small modification on the content and save
- Go to the translation editor and check if the fields are displayed here

Please let me know if it worked for you.

Regards,
Diego

September 6, 2018 at 6:01 pm #2711870

nikolayP-6

Already done, otherwise it wouldn't show up at all. It's showing up and can be translated, but it's displayed as a small field, I'd like it to be expanded with visual editing like it's on the original language.

September 6, 2018 at 7:55 pm #2712186

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

You can use this steps to switch to the manual editor:
- Go to WPML > Settings
- Scroll to "How to translate posts and pages"
- Select Create translations manually and save
- Do a small modification on the content of the page (original language)
- Edit the translation

Please let me know if it worked for you.

Regards,
Diego

September 7, 2018 at 8:37 am #2713799

nikolayP-6

I don't want to translate my pages manually. I want to use existing translation method with expanded ACF field. Is this possible or not?

September 7, 2018 at 10:37 am #2714158

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Los_Angeles (GMT-08:00)

Hello

Diego is not available today so I will be helping you with your question. I hope that´s okay with you.

You can set the way the custom field appears in the editor by setting additional XML tag, "style = "visual" for that particular custom field in the
WPML > Settings > Custom XML Configuration tab as described here:
https://wpml.org/documentation/support/language-configuration-files/#custom-fields

The example you are looking for is highlighed in the attached image.
Here is the sample XML you are looking to create - you have to put your own values of course.

<custom-field action="translate" style="visual" label="Some content" >custom-fieldname</custom-field>

I hope this is what you were looking for. If you need further help, please let me know.

September 9, 2018 at 4:32 pm #2718060

nikolayP-6

Hi, Yvette!

Looks like just what I needed, thank you!

September 12, 2018 at 2:51 pm #2727996

nikolayP-6

To anyone else with this issue, you actually need to manually specify that the field should be “visual” in wpml-config.xml or in /wp-admin/admin.php?page=wpml-translation-management%2Fmenu%2Fsettings&sm=custom-xml-config

Working example:

<wpml-config>
    <custom-fields>
        <custom-field action="translate" style="visual">YOURFIELDNAME</custom-field>
    </custom-fields>
</wpml-config>