Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.86 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 18 replies, has 4 voices.

Last updated by Bigul 1 year, 11 months ago.

Assigned support staff: Andrey.

Author Posts
April 21, 2017 at 11:25 am #1258927

paulinaS-2

I am using WPML and ACF Pro.
I have a custom post type for apartments for sale. They have ACF of various types including radio which has numerical value (1,2,3) and labels. Whole fields group has been translated following your instructions. Radio buttons in translation have the same values (numerical) and translated labels.
I want translated posts to be duplicates of original ones (so if a field is changed in original it changes accordingly in translated version). It seams to be working on backend side (I can see the same values) but it is not on frontend. When I change value in original version and then go to translated version's frontend I would see not translated labels. I have to go to backend of translated version and simply save it and then it works fine. Which means that it is not enough to change original version but I have to edit translated version everytime as well (which is crazy when I update posts in bulk import).
How t can be solved?

April 24, 2017 at 3:51 am #1259861

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello @paulinas-2,

Thank you for contacting WPML support. I'd be happy to help you on this.

I am not totally sure about this issue, so Can you please elaborate a little more so I can better understand?

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Do you mean to say that each time you update original posts you need to update it's translations too, to see the updated changes?

I look forward to your reply.

Thanks

May 15, 2017 at 11:58 pm #1276704

paulinaS-2

Yes, this is exactly how it is - I need to update translation every time I update original post.
Here you have a short video illustrating that
hidden link

Best regards
Paulina

May 16, 2017 at 12:11 pm #1277131

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

I am Bigul from WPML support team. Shekhar is on vacation. So I am taking care of this ticket. Hope it will be okay for you.

Thank you for the screencast. Are you getting the similar result when Translating the Posts to the secondary language? Please check and let me know your feedback. Also, share me the translation settings of these fields.

It would be nice if you can provide me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

--
With Regards

Bigul

May 17, 2017 at 4:41 am #1277757

paulinaS-2

Hi,
The problem is that the translated post updates but displays the original version of ACF labels. I don't know how to check if it would be the same if I translate duplicated post itself because then there is no translated label to be taken from somewhere else.
The debug information are here https://pastebin.com/1zrrbAsX
Thank you in advance for your help
Paulina

May 17, 2017 at 1:56 pm #1278276

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for the updates. I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue locally.

--
With Regards

Bigul

May 25, 2017 at 6:00 am #1284150

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the login information. I have downloaded your duplicator package now. Will debug it locally and get back to you soon. Please wait.

--
With Regards

Bigul

May 26, 2017 at 8:00 am #1285093

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

For your kind information, it is working for me partially after I followed the steps.

1) Activate ACF Multilingual plugin
2) Set Translated Preferences for ACF Custom fields(*Copy* for the time being)
3) Set Translation Preferences for Oxygen Template Custom fields
4) Translated the ACF Fields label from ACF Custom Field Group Edit Screen

Please check the attached images and following tutorial for more details.

https://wpml.org/documentation/plugins-compatibility/translate-sites-built-with-acf/

But still, I am not getting the correct result for ACF Fields labels in secondary language. May it will be a compatibility issue between WPML and Oxygen templates. I will debug it more and get back to you. Please wait.

--
With Regards

Bigul

May 31, 2017 at 3:46 pm #1288626

paulinaS-2

Hi,
What you achieved is exactly what I achieved. As far as I understand you didn't manage to solve the problem. When do you think you will be able to come back with some kind of solution (your last response was almost a week ago)?
Please also check that if the second language post is a duplicate of the original it doesn't copy image and file custom fields.
Using two major plugins (WPML and ACF) that claim to be compatible I would expect they would work together but they seem to not work as they should.

Best regards
Paulina

June 1, 2017 at 8:16 am #1289112

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

For your kind information, ACF and WPML are compatible plugins. But this issue is happening because *Lokale* post type is using Oxygen builder template. Now not getting expected result for all translated Posts when I translate the template to English. So I have forwarded the details to our second tier team and debugging it with their help.

Maybe this will be happening because of misconfiguration or compatibility issue. We are still working on this issue. Sorry for the inconveniences and delay. It has happened because of the weekend and somehow I forgot to update you the status on Tuesday. Please wait.

--
With Regards

Bigul

June 1, 2017 at 8:50 am #1289152

paulinaS-2

Dear Bigul,
I can understand that display issue may be related with some incompatibilities with Oxygen plugin. However, there is also a problem with ACF image fields that are not copied to the second language - this can nothing to do with Oxygen, there is a problem on the backend. Can you check that as well?

Best regards
Paulina

June 1, 2017 at 1:45 pm #1289464

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for the updates. Please try the following steps after a full site backup and make sure you are getting the expected result for the image field.

1) Activate ACF Multilingual plugin(you can download it from WPML.org>>My Accounts>>Downloads)
2) Visit WPML>>Translation Management>>Multilinugal Content Setup, scroll down to *Custom Fields* section
3) Then choose *Copy* option for the ACF image field and save the settings
4) Create a new post and duplicate/translate it to the secondary language

Please check the following tutorial for more details.

https://wpml.org/documentation/plugins-compatibility/translate-sites-built-with-acf/

--
With Regards

Bigul

June 7, 2017 at 10:02 am #1292952

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

For your kind information, I am escalating this ticket to our second tier team for further debugging. I will get back to you when I have a feedback from them. Please wait. Thank you for your patience.

--
With Regards

Bigul

June 13, 2017 at 2:38 pm #1297428

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Hello,

This is Andrey here from WPML support. Bigul has passed your ticket to me. I got the access details. I will take a look and update you here as soon as I know more.

June 13, 2017 at 3:29 pm #1297500

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

I have tested this with the radio types fields on the fresh install, and I can see the same as you wrote in your very first reply, that everything looks good for the backend.

I'd like to know how exactly you display the custom fields on the frontend? Are you using some specific code? Or something else?
I need this to know to try to replicate the same problem for further debugging it.