Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 5 voices.

Last updated by Dimitri 4 years, 5 months ago.

Assigned support staff: Tia.

Author Posts
March 31, 2016 at 7:58 am #849699

Dimitri

Hi any news on this issue?

Thanks

March 31, 2016 at 9:45 pm #850607

Tia

Hello, Dimitri.

I am almost finished debugging and will post my feedback shortly.

March 31, 2016 at 11:13 pm #850640

Tia

Thank you for your patience.

I have finished debugging and cannot locate the issue.

We have had recent updates to WPML plugins which may resolve this issue. ** IMPORTANT ** Please backup a working copy of site files and database before continuing.

If the issue is not resolved then it is likely something within the video plugin itself and in that case I will escalate to 2nd Tier.

Please let me know the outcome.

April 1, 2016 at 7:28 am #850785

Dimitri

Hi,

which video plugin do you refer? there is no video plugin here just Advanced Custom fields and WPML..

anyway I'll try the update

April 1, 2016 at 8:06 am #850828

Dimitri

No progress even with updates...

April 1, 2016 at 7:31 pm #851502

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

My name is Bobby and I have taken over your ticket for Tia while she is away today. I hope that is okay with you. 🙂

to continue debuging your issue may i kindly ask you to please , turn on your WordPress debug.
From this page:
http://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . 'https://cdn.wpml.org/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents with google drive or dropbox

Kind Regards,
Bobby

April 1, 2016 at 7:43 pm #851509

Dimitri

Hi,

here you are: http://pastebin.com/HyTKsuUe

D.

April 4, 2016 at 4:52 pm #852850

Tia

"which video plugin do you refer? there is no video plugin here just Advanced Custom fields and WPML"

Apologies, I meant with the display of the videos itself which is part of the Advanced Custom Fields: Repeater Field plugin.

I am looking through the error logs and I will respond shortly with a conclusion.

April 5, 2016 at 6:12 am #853157

Tia

Hello, Dimitri. The issue has been solved.

The issue was in soluzioni-single.php around line 163. The line contained the Italian language hardcoded with 'it':

$it_post_id = icl_object_id($post->ID, 'soluzioni_section', FALSE, 'it');

I have switched this to the following:

$it_post_id = icl_object_id($post->ID, 'soluzioni_section', FALSE, ICL_LANGUAGE_CODE );

The page is now bringing up the correct text:

English:
hidden link

Italian:
hidden link

Please let me know if this resolves your issue or if you still need help.

April 5, 2016 at 7:29 am #853219

Dimitri

Hi,

thank you very much for solving my problem.

Kind regards