This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Riffaz 2 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
July 9, 2019 at 3:37 pm #4172619

alexisP-9

I am trying to: showing two different images across English and French versions

Link to a page where the issue can be seen: hidden link

I expected to see: the Maltese dog picture should change to another picture when selecting French

Instead, I got: the same image

I have a repeater image as below. I've set the field "blocks_0_background_image" to "copy"

and "_blocks_0_background_image" to "translate" (image as below) And I've used the "Media

Translation" in WPML menu to translate the Maltese image to another image (from English to

French, image as below).

However, the image on the page seems the same after switching the language from

English to French. In fact even I changed both field "blocks_0_background_image" and

"_blocks_0_background_image" to both translate or both copy. It doesn't work either. But I

assume it has to use "translate" for showing a different image for a different language ? For

switching the image, the WordPress featured image seems working perfectly but not for image

of ACF repeater.

Is there any additional setting I have to do to make it work ? or Is there any wrong with the

current setting I have ?

Thanks A lot,
Chris

July 10, 2019 at 6:07 am #4176251

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I noticed from your debug information that you have not yet install the glue plugin Advanced Custom Fields Multilingual. Could you please download it from your wpml.org account and install/activate it on your site.

Please follow our documentation on how to translate site with ACF.

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Hope this helps.

Kind regards,
Dennis

July 10, 2019 at 10:41 am #4178859

alexisP-9

Hi,

Thank you for your support, I've installed this plugin and the image translation seems working ok now, however, I've noticed some text translations seems not working after installing this plugin (it was working before installing this plugin), please see the attached images and the link

hidden link

For our repeater which has 5 repeating elements in it, the first two don’t translate and the last 3 do, even though they are all the same.

I've set the text translation for Italian for "blocks_1_text_content" and "blocks_1_title" but it doesn't switch the text after changing to Italian (in fact, none of any other language works). but "blocks_2_text_content" and "blocks_2_title" works (blocks 2 3 4 5 all work but block 0 and 1 don't work)

the setting for those blocks is "translate" and the system field for those blocks is all "don't translate", is there any reason that causing those have different results ?

July 11, 2019 at 6:40 am #4186371

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your update.

Please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then:

-edit the page having issue. edit it on default language.
-make a small change on one of the custom fields value. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages.

Kind regards,
Dennis

July 11, 2019 at 4:24 pm #4191883

alexisP-9

Hi,

Thank you for your reply.

I've increased the memory limit and max input vars. I also did the steps above, update the page, however, the first and second elements of the repeater still don't have any translation even it does have translation in the translation management.

If I create a new element in English and set up the translation for this new element, this element will only appear in the default language (English) but not in any other language.

Is there other steps that I might've missed ? Thanks

July 12, 2019 at 9:06 am #4196779

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Based on the screenshot on your previous message, I noticed that 'Multibyte String extension' is not loaded. Multibyte String extension is required for WPML String Translation to work properly.

https://wpml.org/home/minimum-requirements/

I recommend asking for support from hosting service on this issue and find out with them if the extension is enabled.

If the issue still persists, even after complying the above server requirements, I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

July 15, 2019 at 4:17 pm #4213221

alexisP-9

Hi Dennis,

Thank you for your support, the migration is done. Thanks.

Regards,
Chris

July 16, 2019 at 4:32 am #4216057

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I tried to translate the page (Applications page ) to Dutch, but I noticed an error on the browser console while saving the page. The page is stuck after saving. However, when I viewed the dutch translation, the page is now seems to be translated.

hidden link

On your site, does the error something like 'the server responded with a status of 502 (Bad Gateway)' also occur when you try to save translation of the page having issues?

If yes, it seems that the problem with translations could be related to mySQL configuration of your server. Could you please verify the following value in the my.ini file in the folder for mySQL 5.6.10

max_allowed_packet=64M

Please increase the value for this configuration and translate the pages again. If the translation is unsuccessful, increase the value again (example: 128M).

You might need some assistance from your host to properly set this up.

Please let me know how it goes.

Kind regards,
Dennis

July 18, 2019 at 8:21 am #4235981

alexisP-9

Hi Dennis,

thank you for your support, our production site doesn't throw out the same error while saving the translation page but we are still getting the host to increase max_allowed_packet. we will tell you how this goes once this is done. thank you

Regards,
Chris

July 18, 2019 at 9:30 am #4236773

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply. Please let me know your results then after applying the suggested solution.

Kind regards,
Dennis

July 23, 2019 at 8:30 am #4263897

alexisP-9

Thanks Dennis, we are waiting on the client to update the server. Please keep the ticket open - We will update as soon as we hear from them with the latest status.

Thanks for your continued help.

July 23, 2019 at 10:26 am #4265107

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

I will wait for your results. However, our system will automatically close tickets if you don't respond after some time. It will send you a reminder email though.

Kind regards,
Dennis

July 24, 2019 at 2:24 pm #4275537

alexisP-9

Thanks Dennis. Just posting this message to ensure that it is not automatically closed!

July 25, 2019 at 9:39 am #4281405

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

You don't have to worry to much. I think the system will close the ticket after one month of no activity.

Kind regards,
Dennis

August 1, 2019 at 9:56 am #4320307

alexisP-9

Got a message about a bot shutting this down so just posting an update that we are waiting on an update from the client.

The topic ‘[Closed] ACF Repeater Image not changing’ is closed to new replies.