This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Bigul 8 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
January 17, 2019 at 2:45 pm #3102481

ramon

I am trying to translate acf fields, but when I use the function get_field_object from the acf plugin, it always returns false on a translated page.

January 18, 2019 at 8:01 am #3104960

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please share with me the following details for tracking the issue.

a) Have you set *Copy* or *Translate* as the translation preference for the ACF Selector Field?

b) Are you using Advanced Custom Fields Multilingual plugin? If not, please take a site backup and try once again after activating the latest version of Advanced Custom Fields Multilingual(1.0.4) plugin. Please check the following documentation for more details.

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

c) To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

January 18, 2019 at 9:36 am #3105320

ramon

I have tried both Translate and Copy neither seem to work, at the moment I am using translate, I do have the Advanced Custom Fields Multilingual plugin installed

January 18, 2019 at 1:18 pm #3106024

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please let me know the following information for tracking the issue.

a) Please share me the code block you are using for to list ACF Selector Field

b) Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

January 21, 2019 at 11:45 am #3112113

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul is off for today, so I am taking care of this ticket today, I hope this is Ok. 🙂

I can see that on the site details you provided, you haven't provided HTTP authentication at all, could you please provide those details too, you can edit your previous private reply to send those login details.

Look forward to your reply.

Thanks

January 21, 2019 at 11:51 am #3112145

ramon

Ok, I updated it

January 22, 2019 at 8:49 am #3115142

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. Please try the following sample code after a site backup and check you are getting the expected result or not.

$example = get_field('example');

echo $example['value'];

echo $example['label'];

--
Thanks!

Bigul

January 22, 2019 at 9:41 am #3115430

ramon

Hello,

$example['value'] and $example['label'] only return the letter "v".

January 22, 2019 at 5:31 pm #3117672

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share me the steps to replicate the issue on your site(the page or post you are calling this field).

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

January 28, 2019 at 9:28 am #3134671

ramon

Steps:
go to portugues version: hidden link it has the text,
go to english version: hidden link it doesnt have the text

Sure, go ahead

January 28, 2019 at 6:20 pm #3137195

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please check the attached image. Those strings are missing in English, am I right?

I have a request. We have released a new version of WPML(4.1.4). Please upgrade to the latest version of the WPML and WooCommerce after a full site backup and check is there any difference in the result.

--
Thanks!

Bigul

January 29, 2019 at 10:57 am #3139267

ramon

Hello,
Those are the missing strings, also i tried to update both wpml and woocommerce with no luck

January 29, 2019 at 6:51 pm #3141350

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

January 30, 2019 at 4:45 pm #3145040

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the issue was happening because of a compatibility issue. It works for me after choosing *Copy* as the translation preference for the system fields of the ACF select custom fields. Please check the attached images for more details.

Please try the following steps after a site backup and make sure you are getting the expected result or not.

1) Open *Julia Kemper Aragonez* product for edit in Portuguese
2) Scroll down to *Multilingual Content Setup* widget on the bottom of the screen
3) Click on *Show System fields* link
4) Choose *Copy* as the translation preference for the system fields like _tipo_de_vinho, _capacidade etc..
5) Apply the changes
6) Then update the Products in both languages (just resave)

--
Thanks!

Bigul