This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Shekhar Bhandari 2 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 31, 2019 at 9:41 am #4313353

Dieter

We use ACF Pro with WPML, WPML Translation Management, WPML String Translation, ACF Multilingual and try to translate repeater fields using this guide:

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#setting-the-translation-preference-for-repeater-fields

Steps:

1. Set repeater field to COPY in ACF field settings.
2. Set repeater subfields to TRANSLATE in ACF field settings.
3. In page, set system field _repeater to COPY.
4. Click on apply.

Issues:

1. After clicking on apply and going back to the page overview, the page where we set _repeater to COPY just duplicated itself 31 times in the same language.

2. The new advanced translation editor of WPML displays too much fields. Examples:

- Repeater has 9 child entries. But 10 translatable fields are shown. One field has the value "Zul. Gesamtgewicht 21000kg, Stützlast 3000kg", but it is split into "Zul." and the rest.

- There is another repeater field with nested repeater fields of the same name as the translatable one (not nested). This causes the translation editor to show them even they are marked as DON'T TRANSLATE.

July 31, 2019 at 6:51 pm #4317293

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please share the URL of the page you are having the issue for the easy navigation to find the problems.

--
Thanks!

Bigul

August 1, 2019 at 5:45 pm #4324583

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information and updates. I checked the *Abschiebewagen Gigant ASW 271*. Now most of the ACF fields translation preference is set as *Don't translate* for an example for the fields like *Anschrift* and *Kontakt*. But the site is loading very slowly for me and not able to connect with Advance Translation Editor.

Therefore can you please share a couple of screenshots for a better understanding of the issue.

--
Thanks!

Bigul

August 5, 2019 at 7:29 am #4338565

Dieter

I have made a couple of screenshots with descriptions. Hope that helps.

August 5, 2019 at 6:18 pm #4342549

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. This may be a conflict in the settings. I would like to do you have any special settings on the site now. Becuase Dashboard Menus like Appearance>>Themes, Settings>>Permalinks, etc.. are missing for me. Please check and let me know your feedback.

--
Thanks!

Bigul

August 6, 2019 at 6:36 am #4344409

Dieter

Hi,

most menu items in WordPress backend are disabled for the customer. This is not the issue.

I have enabled them for you.

Kind regards

August 6, 2019 at 5:49 pm #4349813

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

4) Then complete the English translation of *Abschiebewagen Gigant ASW 271* page

5) Update *Abschiebewagen Gigant ASW 271* page after a minor change to refresh the translation settings

6) Then open the translation of *Abschiebewagen Gigant ASW 271* page and make sure the issue is existing or not

--
Thanks!

Bigul

August 7, 2019 at 8:54 am #4352937

Dieter

Hi,

I've followed all the steps thoroughly, but the issue still persists.

All entries are doubled as before, but the second word "neu/new" that I have added before updating the page (step 5, minor change) has not been duplicated. There are now three of them, not four.

Any other solution?

Kind regards

August 7, 2019 at 1:34 pm #4355491

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. It requires further checking. So please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 8, 2019 at 6:53 am #4360159

Dieter

Currently, this is a development site with demo content. So feel free to duplicate it.

Thanks for the effort!

August 9, 2019 at 6:35 am #4367701

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul is not available today. Since he is aware of the issue in-depth, I would like to ask if it's ok to wait for him. He will be back on Monday.

Besides that I have normally checked the issue and here are my few suggestions so can you check it.

#1
Repeater Fields

Suppose you have a repeater field (repeater) and it's has a "firstname" field inside it, to translate the first name field, you should follow the below steps:

- Go to the page/post where it's added
- Go to Multilingual content setup metabox in the bottom
- Click on show system fields
- Now mark "repeater" field as copy and "firstname" field as translate
- Now mark the system fields _repeater and _repeater_firstname to as copy.

Here is a video showing the same thing: hidden link

#2

 After clicking on apply and going back to the page overview, the page where we set _repeater to COPY just duplicated itself 31 times in the same language.

Could you elaborate on this? I am not sure about this one.

#3

- The repeater has 9 child entries. But 10 translatable fields are shown. One field has the value "Zul. Gesamtgewicht 21000kg, Stützlast 3000kg", but it is split into "Zul." and the rest.

The advanced translation editor segments the texts to make the translation easy so this is normal. You can translate it easily, isn't it?

If you see that the segmentation creates translation issues add all the translations at one of the segmented fields and leave other fields empty.

#4

- There is another repeater field with nested repeater fields of the same name as the translatable one (not nested). This causes the translation editor to show them even they are marked as DON'T TRANSLATE.

I can see the repeater fields "types" is set a don't translate but I can see it's individual fields are marked as translate so it must be appearing in the translation editor, just mark those individual fields too as don't translate and it should be ok.

Suggestion
I can see you have a similar field name for two of your repeater fields, this is not a recommended way to name your fields so I request you to use unique fields names for each of your repeaters.

Look forward to your reply.

Thanks

The topic ‘[Closed] ACF translation not working as expected’ is closed to new replies.