Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by rolfv 6 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 18, 2019 at 4:15 pm #3640717

rolfv

Quick question.

I am trying to: After we activated the plugin "Advanced Custom Fields Multilingual" all the fields in the frontend disappeared.

Link to a page where the issue can be seen:
We put back a backup.

Is there a possibility that Advanced Custom Fields Multilingual broke all the references?
If we activated ACFM, the ACF fields in the frontend where hidden. If we deactivated the plugin they were visible again.

Please note, the plugins in the screenshot are not updated because of the setback.

April 18, 2019 at 4:49 pm #3640897

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Can you please, provide me with the full details on how to replicate this issue in your website? It will help me to understand what's the cause of your issue. Also, I would need to take a detailed look in your WordPress Dashboard, for that, please consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 23, 2019 at 8:29 pm #3667579

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Please, take a look at my private reply above. Thanks!

April 24, 2019 at 12:35 pm #3672761

rolfv

Hello Marcos,

I really appreciate your efforts!

The WordPress is migrated. I tried to update the plugins in the test version. The WPML plugins can't be updated in the current test site. If it isn't possible to recreate the problem, I can upload the backupped broken version of the WordPress.

If there is any missing information, please let us know.

Kind regards,
Roy van der Zon

April 25, 2019 at 6:10 pm #3684903

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for the updates. I am trying to debug your website using our cloudways environment, I still see no difference with the acf fields groups in your website backend when keeping ACF activated/deactivated, in which page you are using the fields so I can see the results in the frontend? Also, please, keep in mind as ACFML version 1.1 you are able to define how the fields will be translated on a fields base as you can read the full details at: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/.

Please, let me know the full details on how to see the fields issue on the frontend so I can proceed with the issue investigation. Thank you for your continued patience and understanding. Have a nice day.

April 29, 2019 at 6:35 pm #3706149

rolfv

Hi Marcos,

I have a zipped WordPress snapshot from the moment the plugin was broken. The MYSQL is included. How can I add a private message to this thread?

Kind regards,
Roy van der Zon

April 29, 2019 at 7:43 pm #3706341

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for the updates. I've enabled a private reply for you, this way you can safely send these details. Thank you for your collaboration, have a nice day.

May 3, 2019 at 10:21 pm #3738243

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for the provided details. I took a look in your file and notice the file is too big 1GB+ is there any means of excluding the wp-content/uploads folder and any other media from you package? Is it preferable to have a simple export of your database tables in the SQL format and a minimum wp-content folder containing only your theme files and some necessary plugins to replicate the issue. If it is not possible then I can proceed and give a try for your file, although it delays a bit the resolution of your issue. Thank you for your collaboration, have a nice day.

May 7, 2019 at 6:40 am #3754449

rolfv

Hi Marcos,

We've updated the ACF and WPML plugins and the following thing has happened: All the settings ACF fields are only translated in dutch, for example the DE translations are set back to the dutch translation.

We want to set back a backup from yesterday as soon as possible, can you please have a look first in the current WordPress? The previous mentioned login (info@wpml.org) is still working.

If you can't look, please let us know as well, then we will set back a backup immediately.

Kind regards,
Roy van der Zon

May 7, 2019 at 7:56 am #3755037

rolfv

Hi Marcus,

We have to set back a backup because there are some campaigns running. Our apologies.
I will attach a zip file with some debug information I gathered from the WordPress.

It looks like when we update the Advanced Custom Fields Multilingual plugin and the WPML Multilingual CMS plugins, most of the custom fields are replaced with the default content.
In the "configurate mulilanguage content" settings in the pages are the most specific fields on "translate" and very few on "copy".

Is there something wrong with the update, or are the settings conflicting with the new update?

Your help is much appreciated!

hidden link

Kind regards,
Roy van der Zon

May 9, 2019 at 1:18 am #3771751

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for the provided details. I would need some extra hours to migrate and fully debug your website content in order to understand what's happening in your website. I will update you here in the next hours as soon as I have some conclusion. Thank you for your continued patience and understanding, have a nice day.

May 9, 2019 at 6:14 am #3773237

rolfv

Hi Marcos,

Thank you for your effort. Take your time and if you need something, let us know.

May 10, 2019 at 8:13 pm #3787711

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for your contined patience while waiting for a solution. I took a detailed look in your website and noticed the fields group field values are all in the default language (dutch) does it happen on the ACFML update? I also noticed all the fields labels are in the default language, have you translated it and then the translations were missing on the update? If I understood your request properly, you missed all your field content translations on the ACFML update, right? It seems to be caused due the changes from ACFLM 1.1 where you would need to review your translations preferences for every field as you can read at: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#making-acf-fields-translatable. Did you notice it when updating? Please, let me know these details. Have a nice day.

May 13, 2019 at 10:48 am #3797191

rolfv

Hi Marcos,

Thank you for your time, I'll read the article you send, follow the steps and update the website. When finished I'll place my findings in this thread. When the problem is resolved I'll close this thread.

Again, thank you for your time.

Kind regards,
Roy van der Zon

May 13, 2019 at 6:52 pm #3801251

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Roy,

Thank you for the updates. Please, feel free to get in touch as soon as you are done with your tests. Have a nice day.