This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 6, 2019 at 6:09 pm #3751811

webA-3

Tell us what you are trying to do?

Is there any documentation that you are following? I did all the steps listed here: https://wpml.org/forums/topic/images-not-displaying-on-translated-site/
I did all these things: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Is there a similar example that we can see? hidden link

What is the link to your site? hidden link The press page, above has the issue with the images. I have not done the merchants yet as they have a structure similar to press.

May 6, 2019 at 8:07 pm #3752499

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

May 6, 2019 at 8:11 pm #3752511

webA-3

If you click the link I provided: hidden link you will see that the english version has images for featured press, but the spanish version does not.

May 7, 2019 at 10:09 am #3756237

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Does the issue persists after increasing the memory limit?

Regards,
Carlos

May 7, 2019 at 12:56 pm #3757997

webA-3

I increased my memory like instructed above, but I still do not have images for my featured press in the Spanish translation. I looked at the code for the Spanish translation and instead of the image URL the Spanish version has what looks like an image id?

May 7, 2019 at 1:19 pm #3758201

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 8, 2019 at 10:25 am #3765539

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue isolating the cause of this issue I need to ask you to update all outdated plugins and themes to their latest version and flush any cache memory that might exists.

Note: Please don't forget to create a full backup of the site before making any change.

Could you tell me if the issue persists after the steps above?

Regards,
Carlos

May 8, 2019 at 1:24 pm #3767147

webA-3

I updated all the plugins or deleted them if not in use. There is no cache activated for this site since it is a staging site, but I flushed cache anyway. I still have the issue.

May 8, 2019 at 6:38 pm #3770039

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I took a deeper look at this issue and the content of the page is created in the Page template. Which means that the problem is in the code that created this template and to fix it you will need custom code which falls outside of our scope as a support service.

I recommend you to visit this links where you will find useful information:
- hidden link
- https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

At this point I would suggest you consider contacting one of our certified partners from this link:
http://wpml.org/documentation/support/wpml-contractors/

Before doing so please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

You will get the custom assistance you need to get on with your project.

Thank you very much for your understanding!
Best regards,
Carlos

May 8, 2019 at 7:12 pm #3770347

webA-3

I think it is not with my code. I found this thread and several others were people are having similar issues: https://wpml.org/forums/topic/acf-images-get-id-in-traslated-page-instead-of-image-url-2/

I do not understand what this person did to fix the issue. Could you please check to see if my issue could be resolved in a similar fashion?

May 9, 2019 at 12:55 pm #3776253

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your message.

I applied a workaround in the code to show the images in English and Spanish. Please contact the theme's authors and ask them for a final solution.

Regards,
Carlos

May 9, 2019 at 4:00 pm #3777895

webA-3

Thank you for the temporary fix. I found this thread and it looks like the technician found a fix, but I don't see any documentation on doing images this way. Do you think this would be a permanent fix for my issue: https://wpml.org/forums/topic/image-in-custom-field-acf-not-show-in-translation-it-is-a-number/

May 9, 2019 at 10:51 pm #3779703

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I can't guarantee the fix referenced in your previous message will be a final solution as this issue is escalated already to our development team, and our devs are working on a solution to include in a future release.

Regards,
Carlos