This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by pimM-3 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
August 22, 2019 at 8:17 pm

pimM-3

Hi,

This is the second time I post this. Earlier today I could not download a back-up and I had to leave, so I was not able to continue the conversation.

On specific pages ACF do appear in the WPML translator, but not on the translated page itself (to translate them manually). On 80% of the other pages, we are able to translate pages with the WPML translator and/or manually. We need to do both on all pages.

Attached you'll find an image with on the left side the default Dutch translation and on the right side the English translation. In the Dutch translation the ACF are visible, in the English translation not. It seems the ACF field name and type are missing from some field in the English translation.

Please advise.

Thank you.

Pim

August 23, 2019 at 10:47 am #4445981

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

The issue is only happening when we translate the Pages manually and it happens with all the Pages, am I right?

Please click on *Show system fields* link of Multilingual Content Setup widget on the bottom of the screen. After that choose *Copy* as the translation option for the ACF System fields, you are trying to translate and apply changes. Then make sure the issue is existing or not.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

August 26, 2019 at 6:04 am #4456069

pimM-3

Hi Bigul,

Thank you for your answer.

What you said about the issue is exactly not happening what I described. I will try it again.

Almost every page in the website we are able to translate via the WPML Translation editor from the default language to another language (in our case from Dutch to English). We are also able, when the duplicate page of the default language in the new language is ready, to make changes manually on the translated page itself.

So to illustrate:
1. We have a Home page in Dutch
2. We used the WPML Translation editor to translate the Dutch Home page to English (in other words make a duplicate page with some translations)
3. Under Pages, selecting the English language and then selecting the Home page in English, we are able to make adjustments on the English version of the Home page itself manually.

This works for nearly all pages, except for a specific number of pages. These pages are grandchild pages.

It appears that for some ACF the system fields counterparts are not copied over to the translated page.

I have tried what you suggested, didn't work. The system field is not being copied to the translated page.

Hope hearing from you soon.

Thank you!

Pim

August 26, 2019 at 5:16 pm #4460491

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Thank you for the details. It requires further checking. So please allow me to make a fresh Duplicator package of your site to debug the issue on my local server.

--
Thanks!

Bigul

August 27, 2019 at 6:19 am #4462965

pimM-3

Hi Bigul,

You have all the information. I already provided login details and a link to a duplicator ZIP file.

I really am in need of an answer, my deadline is Thursday and still some pages need to be translated.

Keep me informed.

Thank you!

Pim

August 27, 2019 at 6:55 pm #4469177

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Thank you for the updates and permission. The bug is existing on my local copy after the initial debugging steps. So I am checking about this with our team and get back to you soon. Please wait.

--
Thanks!

Bigul

August 28, 2019 at 8:29 am #4472073

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

For your kind updates, I have escalated the ticket to our Compatibility team for further debugging. We will get back to you soon when we have an update from our Compatibility team. Please wait.

--
Thanks!

Bigul

August 29, 2019 at 6:28 am #4477989

pimM-3

Hey Bigul,

Do you have an answer for me?

Hope hearing from you.

Gr. Pim

August 29, 2019 at 11:53 am #4480585

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

For your kind information, the bug is existing after the detailed debugging. So the ticket is escalated to our developers for fixing. We will get back to soon when we have a feedback from our developers on this. Please wait.

--
Thanks!

Bigul

September 1, 2019 at 2:51 pm #4492653

pimM-3

Hi Bigul,

I has been three days since your last reaction. I really am in need of a solution.

I already had to inform my client about it.

Please let me know if there is any news. Thank you!

Pim

September 5, 2019 at 9:57 am #4518129

pimM-3

Hi Bigul,

It now has been a full week since we last spoke.

Please give me an update and an ETA.

Thank you.

Pim

September 6, 2019 at 1:03 pm #4525433

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

For your kind updates, our developers are still working on this fix now. But as of now, I don't have the exact time frame required for the fix. We will get back to soon when we have an update from our developers on this. Sorry for the inconvenience. Please wait.

--
Thanks!

Bigul

September 9, 2019 at 7:34 pm #4539917

pimM-3

Hi,

I'm one step further. I've managed to make the translated pages editable again, all the field are now showing (before they weren't).

When creating field groups in ACF you can set rules where the fields should be displayed. I my case I had: "show field group when page parent is equal to a certain sub page". In the default language the field group was shown on the right pages (and thus fully editable). However, when translating these pages, the field group was not visible on the translated pages.

After trying many things I discovered that setting the field group rules slightly different solved part of my problem. I now use the following rules: "show field group when post category is equal to the category the page is linked to". The rules display the field group on the same pages, but with different rules. And yes, I use categories on my pages. Technically I'm not sure why one set of rules isn't working and the other is.

Having solved part one, now I have to tackle part two.

On these specific grandchild pages (mentioned earlier) I use the ACF Repeater, in order to let the client create as many items as he sees fit. Here the problem is these fields are not translated.

On the translated pages, all the fields are visible, but the input of the ACF Repeater is gone. I can recreate everything, but they still will not show on the frontend. I tried setting its system field counterparts to copy, doesn't work either.

Any idea now that I myself have narrowed the problem?

Hope hearing from you soon.

Pim

September 9, 2019 at 8:45 pm #4540135

pimM-3

Hi,

I'm again one step closer. Setting all related system fields to "copy" worked, the ACF Repeater input is visible in the backend, but not the frontend. Strange!

In the attached image you can see what I've done. Am I missing something?

Is it possible that I have old fields showing up here? What is marked green is actually what I am using at the moment.

Please advice.

Pim

September 10, 2019 at 12:55 pm #4545445

pimM-3

The last piece of the puzzle was the following.

I use a WPML compliant plugin named Anywhere Elementor, which let you create your own post items within a grid, carousel, repeater, etc. In order for WPML to work correctly also these posts need to be translated. Translating the repeater post did not translate my actual settings. So after adding them again in the translated post, I was able to get it to work.

My issue is resolved now. Thank you!