This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.43 hours from now. Thank you for your understanding.

This topic contains 19 replies, has 2 voices.

Last updated by Riffaz 1 month, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
August 3, 2019 at 12:22 pm #4334503

veronicaC-5

Tell us what you are trying to do? I am trying to use advanced translation Editor. I select the option to use it and it says it is enabled but not active

Is there any documentation that you are following? WPML forum

Is there a similar example that we can see?

What is the link to your site? hidden link

August 4, 2019 at 6:03 am #4335681

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

When you activate the ATE, you will receive an email .
Did you receive that email?

Let me know.

Regards,

August 4, 2019 at 12:29 pm #4336353

veronicaC-5

Hi,
No, I have not received any activation email.

Do I have to do something to receive this email?

Nevertheless, I can use the ATE and I have already translated several posts, but it still states it's not active, as you can see in the screenshot:

Thank you

August 5, 2019 at 7:06 am #4338375

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The ATE can only be activated by accepting the confirmation email link, that is sent to the site admin. In you case it sees there is not a valid e-mail address on record. Please go to https://wpml.org/account/account-settings/

Check here your registered email. Then apply the same email to your WordPress Admin Profile on your backend (Edit my Profile - Contact Info).

Now deactivate the ATE at WPML-> Settings -> How to translate posts and pages by selecting the Classic Translation Editor. Click save.
Now reactivate the Advanced Translation Editor. Any Email should have reached your mailbox now. Please also check your Spam folder.

Also, I would like to ask to you to check this points:
- Check if the email is in the spam folder.
- Check if you set a translation manager for the site. This is a must.
- Change the email account to use a gmail account and try activating the Advance Translation Editor again.

And, this could be a false positive message as well.
In that case, if you disable and enable the ATE, then it should be fine.

Let me know if this solved the issue.

Regards,

August 6, 2019 at 2:14 pm #4348233

veronicaC-5

Hi,

I have already the same gmail account in the wordpress admin profile and in the wpml account settings. I have deactivated the ATE and reactivated. I have two translation managers set. No email received nor inbox nor spam folder.

August 6, 2019 at 2:16 pm #4348255

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your site login details to check this closely.
The next reply is private.

Regards,

August 6, 2019 at 2:24 pm #4348309

veronicaC-5

Hi,

I don't give my login details ever. But I can send you any screenshot you may need. Hereby in the screenshots you can see my profile email in wordpress and wpml

August 7, 2019 at 8:02 am #4352595

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Actually, you have to set emails for all the users. I mean all the users in you site should have an email set in their profile.
Could you please go to Users and check if all the users have the email or not?

Let me know.

August 12, 2019 at 11:02 pm #4383895

veronicaC-5

Hi,
all the users in my site have an email set in their profile which is the same email. I have three users in my site. Two of them are translators in AMS. The same email registered for each user in the wordpress profile is the email registered in the AMS profile.

August 13, 2019 at 3:09 pm #4389139

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

So,
1. when did you register the ATE ?
2. did you migrate your site from somewhere or did you change your site URL at any point?
3. What is the value when you run this query?

SELECT * FROM wp_options WHERE option_name LIKE '%WPML_SITE_ID%'

4. go to WPML > Settings > how to translate posts and pages

below the ATE settings there will be a link that will send you to a WPML site where you can check the translators permission. in that page there will be a menu on top of the page.

click on website and then go to "site identifier"

check that value and let me know.

Regards,

August 18, 2019 at 11:50 am #4412015

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

you have different site IDs for global and ATE.
That is the issue.

Please follow these steps:
1. Copy these values https://wpml.org/wp-content/uploads/2019/08/4408345-Capture1_2.png and save it in a text file.
2. Both IDs should be same as your site identifier: 36323666-3833-5965-b062-636331613837
So update this https://wpml.org/wp-content/uploads/2019/08/4408345-Capture1_2.png with your site identifier.

Then check the issue.

If that does not help we have to manually update your global ID and site identifier from our relevant department.

Let me know how it goes.

Regards,

August 25, 2019 at 4:08 pm #4454433

veronicaC-5

Hi,

I have updated the ID by modifying directly the line in the database. I have deactivate and reactivate the ATE but it still says it's not active.

August 25, 2019 at 4:10 pm #4454527

veronicaC-5

Also, I haven't received any email asking for activation

August 26, 2019 at 6:24 am #4456145

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for following the steps.

>>> go to WPML > Settings > how to translate posts and pages
> below the ATE settings there will be a link that will send you to a WPML site where you can check the translators permission. in that page there will be a menu on top of the page.
> click on website and then go to "site identifier"
- When you click there, what is the url you are seeing here : hidden link

Regards,

August 26, 2019 at 7:09 am #4456223

veronicaC-5

Hi,

I see my website url: hidden link

The topic ‘[Closed] Activate Advanced Translation Editor’ is closed to new replies.