This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 6 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 28, 2019 at 5:29 am

ericE-5

I am trying to: use WPML

Link to a page where the issue can be seen: Plugins page of admin, hidden link

The WPML plugin is currently deactivated. When I activate it, the site becomes completely broken, no page will load (front end or back end). The only recourse is to restore a site backup. After the backup is restored, the WPML plugin is not activated (the backup was done while deactivated).

Here's a screencast showing the issue: hidden link

March 28, 2019 at 12:14 pm #3480631

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be happening because of the compatibility conflicts. Hope you are activating and configuring WPML for the first time on this site.

Please add the following code in wp-config.php file of your site to enable WordPress to debug mode. It will create a *debug.log* file in *wp-content* folder. Then activate WPML and check you are getting any errors or warnings related to WPML in the log file.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check the following links to read more about debugging with WordPress.

https://codex.wordpress.org/Debugging_in_WordPress

https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

If you are still having the blank page on WordPress dashboard, please log in to FTP and rename the *sitepress-multilingual-cms* folder of *wp-content/plugins* directory. This action will help you deactivate WPML and access the WordPress Dashboard again.

Please note, I am not able to access the login page your site. It redirects me to the site homepage. So please share me the exact login URL.

--
Thanks!

Bigul

March 28, 2019 at 10:38 pm
March 29, 2019 at 6:07 am #3488085

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. Just to make sure, have you translated the Posts or Pages to the secondary language?

If possible please try the following troubleshooting steps and let me know your feedback.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins
d) Activate WPML
e) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

March 29, 2019 at 7:15 am #3488305

ericE-5

I have translated pages (though not all of them, only some).

I the switched the theme to Twenty Nineteen, disabled all plugins and then activated WPML. It still failed, however, this time the following message was displayed:

Fatal error: Uncaught Error: Call to undefined method stdClass::is_enabled() in /home/deralict/webapps/velletta_wp/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php:346 Stack trace: #0 /home/deralict/webapps/velletta_wp/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-inline-styles.php(274): WPML_LS_Settings->get_active_slots() #1 /home/deralict/webapps/velletta_wp/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-admin-ui.php(105): WPML_LS_Inline_Styles->admin_output() #2 /home/deralict/webapps/velletta_wp/wp-includes/class-wp-hook.php(286): WPML_LS_Admin_UI->admin_head_action('') #3 /home/deralict/webapps/velletta_wp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/deralict/webapps/velletta_wp/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/deralict/webapps/velletta_wp/wp-admin/admin-header.php(144): do_action('admin_head') #6 /home/deralict/webapps/vel in /home/deralict/webapps/velletta_wp/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php on line 346

March 29, 2019 at 12:46 pm #3491321

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. This may be happening because of the corrupt entry in the database. As a workaround please try the following steps after a site backup and let me know your feedback.

1) Create a fresh installation. Then activate and configure WPML with the same language of your live site.
2) Log in to the database(of fresh installation), choose *wp_options* table(table prefix may defer your case)
3) Copy the value of *wpml_language_switcher* option
4) Log in to the database of your live site, choose *wp_options* table(table prefix may defer your case)
5) Find *wpml_language_switcher* option
6) Replace the value with the fresh installation value

Please check the related tickets for more details.

https://wpml.org/forums/topic/wpml-ssl-fatal-error/

https://wpml.org/forums/topic/fatal-error-when-activating-wpml-multilingual-cms-on-digital-ocean/

--
Thanks!

Bigul

March 29, 2019 at 4:59 pm #3493173
ericE-5

Following those instructions I was able to successfully get the WPML plugin activated without the error, however none of my translations are showing up (on either back end or front end). See screenshot...all of these pages used to the edit icon for Chinese language translations.

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-translation-is-not-showing-up/

March 30, 2019 at 5:17 am #3497295

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have opened a new ticket for the Translation is not showing up issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul