Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 2 years, 5 months ago.

Assigned support staff: Bobby.

Author Posts
March 5, 2018 at 12:30 pm

mohamedl

I am trying to: activate the plugin in the site (multisite, foodguide theme) and its compatible with wpml

Link to a page where the issue can be seen: plugins page

I expected to see: plugin active

Instead, I got: Fatal error: Cannot redeclare icl_get_home_url() (previously declared in /home/lotfikof/public_html/sandbox/wp-content/plugins/ait-languages/modules/wpml/wpml-legacy-api.php:18) in /home/lotfikof/public_html/sandbox/wp-content/plugins/sitepress-multilingual-cms/inc/template-functions.php on line 77

March 5, 2018 at 6:26 pm #1536761

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

From the error above i can see that the issue is with the plugin ait-languages

what are your results if you deactivate the ait-languages plugin and then try to activate WPML ?

March 6, 2018 at 6:42 am #1537142

mohamedl

hi bobby an thank you
but the whole site is based on those plugins (not just one) the theme n plugin are from the same author

March 6, 2018 at 7:56 pm #1538214

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Which AIT theme are you currently using ? Please make sure that you are using the latest version of the theme.

Are you able to find your theme within the following list ?

=> https://wpml.org/documentation/theme-compatibility/?wpv_view_count=112654&dev%5B%5D=113097&wpv-theme-category=0&wpv_post_search=&wpv_filter_submit=Search

I would also like to take a closer look but the credentials above are not working, if possible please share with me the correct ones.
[private reply enabled]

March 6, 2018 at 9:58 pm
March 7, 2018 at 8:13 pm #1539712

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have checked the info you send before but

"the credentials above are not working, if possible please share with me the correct ones." [screenshot from trying to register attached]

now i was able to login , but i am not an admin user therefore i cannot see anything within the site.
please assign me as an admin user so i can proceed in resolving this issue.

The topic ‘[Closed] activating wpml impossible on site’ is closed to new replies.