This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Yvette 3 months, 1 week ago.

Assigned support staff: Yvette.

Author Posts
July 1, 2019 at 3:02 pm #4120493

sondreB

I am trying to:
I am updating a website with blog that needs to be in two languages. The site has worked without any issues but a few days ago the same project started behaving weird: got blank page in wordpress dashboard and menus page.

I expected to see:
The same behavior that was ok a few days ago. Dashboard working and wordpress pages showing.

Instead, I got:
Blank pages and very slow load times.

I have tried:
- increasing memory through define( 'WP_MEMORY_LIMIT', '256M' ); but it only got the blog and main dashboard page when I set define( 'WP_MEMORY_LIMIT', '2048M' );
- reinstalling the WPML plugins
- Downgrading / upgrading WPML plugins
- Different server

I have looked around for similar problems on the forums but everyone seems to have solved the issue by increasing memory to 256. What could have changed that the plugin needs so much memory and affect the dashboard when everything worked fine to begin with?

July 1, 2019 at 5:08 pm #4121337

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Could you please enable the WordPress Debug mode to see if you are able to capture any informative system messages?

2. Do you know which version of WPML you were upgrading from?
3. Were all non-WPML plugins being upgraded at same time?¡

Thanks for the clarifications.

July 1, 2019 at 7:38 pm #4122035

sondreB

1. Debug mode has been active while I was finding the cause. There are some errors but are unrelated to wpml and are still there if I disable it.
2. I have tried 4.0.7, updated to 4.2.7.1 and then even tried 4.0.0 and 3.9.4. While older versions are not so aggressive on memory, they still cause the blank dashboard issue.
3. I have tried upgrading multilingual CMS, I have tried updating all WPML plugins. I have even tried them all with older versions. If I activate multilingual CMS, I have issues regardless of what other plugins are or are not activated.

July 2, 2019 at 7:35 am #4124707

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Ok.

1. Copy of your site:
https://wpml.org/faq/provide-supporters-copy-site/https://wpml.org/faq/provide-supporters-copy-site/

2. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

Thanks

July 2, 2019 at 2:00 pm #4127621

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Hmmm - to begin, let´s make sure that your environment is meeting all the requirements. I noticed that you do not have mbstrings enabled (see image).

Please let me know when this is done.

Thanks!

July 3, 2019 at 11:54 am #4135609

sondreB

Multibyte String extension has been enabled.

July 4, 2019 at 6:21 am #4140421

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you very much for that. I did some more testing and found that the culprit is surprisingly the Toolset plugin for the blank menu pages.

Could you confirm this on your end?
I will then investigate why this might be the case.

I also noticed that Toolset does not have any types or custom fields defined - are you using this plugin for anything yet?

July 4, 2019 at 7:20 am #4140667

sondreB

Thank you.
No, the plugin came with the theme and since we modified a lot if not all pages, the plugin is not used. I will remove it since that seems to have been the issue.
Only thing now is that the widget to change languages from the header is gone. Setting are there, but no switcher shows in header. Any idea why?

July 4, 2019 at 7:29 am #4140775

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok - does this then resolve your issue?

I can flag to our Toolset team that they should reach out to the theme developer to investigate the compatibility issue if so.

July 4, 2019 at 7:47 am #4140867

sondreB

I have edited the comment a bit late.
The header language switcher is gone. Settings are stil lthe same but the switcher doesn't show.

July 4, 2019 at 8:29 am #4141211

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It seems your menu structure got corrupted and the translation grouping between them.

I adjusted this and now the hambuger icon is appearing and I suppose that this is the language switcher you are using.

I am not sure about the "placement" of the icon within the nav menu - but I leave that to you to customize with the language switcher customization.

July 4, 2019 at 8:29 am #4141213

sondreB

Issue was on our end. As I see it, everything works fine now. Thank you for the support. I will mark as resolved.

July 4, 2019 at 8:30 am #4141219

sondreB

My issue is resolved now. Thank you!

July 4, 2019 at 8:31 am #4141221

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok- glad to hear it.