This thread is resolved. Here is a description of the problem and solution.

Problem: Activation WPML plugin results in white page

Solution:=>https://wpml.org/errata/php-7-possible-issues-simplexml/

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Wolfgang Männel 3 years, 7 months ago.

Assigned support staff: Bobby.

Author Posts
November 21, 2016 at 9:45 pm #1141098

Wolfgang Männel

I am trying to: Install WPML in TheGem theme.

URL of (my) website where problem appears: hidden link (password "cem")

I expected to see: A working plugin.

Instead, I got: A white screen.

Steps to duplicate the issue: I deleted the plugin through FTP. WordPress worked again. Then reinstalled it. Same problem.

November 21, 2016 at 11:19 pm #1141143

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for contacting WPML Support,

Do you get the blank screen as soon as you activate WPML plugin ?

I would like to take a closer look within your error log

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

Also please verify that your site and server are meeting the current minimum requirements to run WPML

Please go to wp-config.php and let me know what is your current WP_Memory_Limit

https://wpml.org/home/minimum-requirements/

=> To see the WP memory limit you have to login using your FTP and going into the
wp-config.php file , and it will be at the very top.
The Documentation i attached for you goes over details the requirements.

Kind Regards,
Bobby

November 22, 2016 at 7:52 am #1141279

Wolfgang Männel

Hi Bobby, I edited the wp_config.php file, increased the memory to 128MB, added the php_info file but now instead of a white page I get this error message:

Fatal error: Uncaught Error: Call to undefined function simplexml_load_file() in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/includes/installer.class.php:652 Stack trace: #0 /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/includes/installer.class.php(66): WP_Installer->load_repositories_list() #1 /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/includes/installer.class.php(37): WP_Installer->__construct() #2 /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/installer.php(7): WP_Installer::instance() #3 /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/installer.php(11): WP_Installer() #4 /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/loader.php(120): include_once('/var/www/html/w...') #5 /var/www/html/wp-includes/plugin.php(524): wpml_installer_instance_delegator('') #6 /var/www/html/wp-settings.php(395): do_a in /var/www/html/wp-content/plugins/sitepress-multilingual-cms/embedded/otgs/installer/includes/installer.class.php on line 652

November 22, 2016 at 3:27 pm #1141790

Wolfgang Männel

Hi guys, please help me with this one as I need to get it working for a client. Thanks!

November 22, 2016 at 5:46 pm #1141921

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please review the following errata documentation and update me

=>https://wpml.org/errata/php-7-possible-issues-simplexml/

Kind Regards,
Bobby

November 22, 2016 at 9:24 pm #1142055

Wolfgang Männel

Hi Bobby, I did what the page told me but even after the terminal command, I got the same error message as before.

November 23, 2016 at 2:02 am #1142113

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

What is your current PHP and MySql Versions ?
Wordpress version ?

If possible have you tested this in a minimal set up .. 3rd party plugins deactivated and default theme (twenty16)

Regards,
Bobby

November 24, 2016 at 8:55 am #1143235

Wolfgang Männel

Bobby, I made a fresh WordPress install on a different droplet and now it seems to work just fine. No idea what caused that. Same droplet type for both instances.