Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 61 replies, has 4 voices.

Last updated by fulvioP 1 year, 6 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
February 13, 2018 at 9:23 am #1515803

fulvioP

Tell us what you are trying to do? I follow many of your suggestion in other post like mine.

Is there any documentation that you are following? Yes, reply like Lauren and Vincenzo.

Is there a similar example that we can see? yes all the slow down site posts in the forum

What is the link to your site? hidden link

I try to deactivate one by one all the plugins but wpml is the only that slow down my site.

February 13, 2018 at 9:30 am #1515812

fulvioP

I hae only activated the WPML and no translation are put inside.

1. I increase the WP Memory to 128Mb

2. Were I can paste the debug informations for you ?

3. I confirm that the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

4. I don't have problem with cpu or ram

February 13, 2018 at 1:36 pm #1516258

fulvioP

Sorry the wp memory now is 512mb but nothing change.

February 14, 2018 at 4:09 pm #1517956

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thank you for following all those pieces of advice in advance.

If you haven't done so until now, please also read our documentation about how to improve and debug performance issues.
https://wpml.org/2012/01/can-your-site-run-faster/
https://wpml.org/faq/how-to-debug-performance-problems/

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations.
We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.
NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

Thanks,
Itamar.

February 15, 2018 at 10:09 am #1518710

fulvioP

Good morning,
debug info attached.

NOTE: I have no check box to provide debug info but only cannot provide them...

February 15, 2018 at 9:55 pm #1519698

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thank you for adding the debug information.
I can see that WordPress itself is not updated to its latest version.
Could you please update WordPress to its latest version and see if it helps?
Before debugging performance issues (or any issue), we always need everything to be updated to the latest version.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

February 16, 2018 at 7:31 am #1519865

fulvioP

Good morning,
I've just update now wp but the problem is the same : from 4 to 9 sec to load a page.
In backend and front end too.
Let me know.
Thank you

February 16, 2018 at 10:57 am #1520111

fulvioP

Look now the time to load on backend page.. it's impossibible to work on th site!

February 18, 2018 at 8:37 pm #1521412

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

I see. Thank you for updating WordPress and attaching the screenshot.
By looking at the debug info, I'm not sure that you are using a caching plugin.
To improve site's performance, we recommend using caching plugin and methods.
Also, do you use some form of Server OPCache plugin (APC or Zend-OP-cache) on your server?
This is recommended and helps a lot in improving performance with any website.

If you do not know the answer to those questions maybe you can find out about it with the support of your hosting company.

Can you, please also share the PHP info of your server with me?

1. To create a phpinfo file, open a plain text file, add the following lines, and save:
Filename: phpinfo.php

<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>

2. Upload the file to the server. You should upload your file to the exact directory you want to test. Typically, this will be your httpdocs (/var/www/vhosts/example.com/httpdocs/) directory, although you can upload it to any subdirectory on your server as well. Use FTP to upload the file.

3. Visit the page in your browser. If you uploaded it to your HTML directory, you should now visit hidden link, replacing example.com with your domain name.

4. Now you can view all of the information about PHP for your server for that particular directory.

5. Tell me when it is done so I can watch this info as well.

Please read more about it here.
hidden link

In addition, the performance of the site also depends on the hardware that your server uses.
Do you have any information about that that you can share with me?
Frequently, shared hosting plans are using low hardware technology.
For instance, are using a shared hosting plan?

Regards,
Itamar.

February 19, 2018 at 8:35 am #1521656

fulvioP

I've just try some cache plugin but not change too much lik w3, but I dont found the plugin that you tell me... have you some links?
I use an Hosting Linux Advanced server.
In attachment a screenshot my php info.
Thank you

February 20, 2018 at 8:44 am #1523172

fulvioP

Now I check on this web site hidden link

You can check the results also this attachment.

Please check and tell me something asap.

Thank you

February 20, 2018 at 1:08 pm #1523583

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

The hidden link test does not show any significant performance issue that is coming from WPML. We are interested to see if there are any server-side implications by WPML.
If you have followed my instructions on phpinfo.php, so you must have a link so I can see the full info (the screenshot shows only part of the information).
Can you please share this link with me?

Thanks,
Itamar.

February 20, 2018 at 2:07 pm #1523666

fulvioP

Now You can visit the phpinfo hidden link

Thank you

February 21, 2018 at 6:14 pm #1525297

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thank you for sharing the PHP info.
Currently, I do not see anything out of the usual on it.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved, I will delete the local site. Let me know if this is ok with you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields, this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Please tell me on which pages do you see the most critical performance issue so I can visit those pages and see the issue myself.

Thanks,
Itamar.

February 24, 2018 at 3:34 pm #1528197

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hello and thank you for the access details.

I've visited many pages on the admin section of your site and also on the front-end, and I can not see the problem of slow loading time. The loading time is usually around two seconds which is quite normal. Please see attached screenshot.
HAve you fixed the problem?
If not, then please tell me how to see it?

Regards,
Itamar.