Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 61 replies, has 4 voices.

Last updated by fulvioP 1 year, 6 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
February 28, 2018 at 8:09 am #1531429

fulvioP

I see a long loading time anyway.
For example 12 sec. to open the main page.
If you deactivate the wpml pluging you can see the difference.
Let me know.
Thank you

February 28, 2018 at 10:06 pm #1532382

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've checked it on the front-page of your site here hidden link.
I've done the check for the first load of the site (browser's cache is clean from cookies of the site).
First I've checked when WPML is active, and then I've checked when WPML is deactivated.
I get less than 3 seconds difference with is quite usual for WPML when taking into account the quiries that it had to make to the DB. Please see attached screenshots.
Most of the loading time is not being caused by WPML.
Can you see that?

Regards,
Itamar.

March 1, 2018 at 9:11 am #1532778

fulvioP

Hello Itamar,
thank you for your reply.
I understand what you mean, but :
1) I can manage other loading problems about images size, script, etc..
2) 3 second for wpml is too much.
Normally 40% of users that visit a website if loading time is more than 4 second they leave the site before come complete loaded.
So, what we can do to reduce your 3 second problem ?
Sorry for my english.. I hope you can understand me.
Kind regards
Fulvio

March 4, 2018 at 12:12 pm #1535411

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Fulvio.

I've just read again all of this ticket to see what you can do to reduce the issue and here is what I've found.

A.
In a previous reply you wrote:
3. I confirm that the following settings are OFF or disabled:
- Adjust IDs for multilingual functionality (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

But when I look in the admin section of your site currently I can see that 'Auto register strings' is enabled for some domains. Please see attached screenshot disable-auto-reg.jpg
Please disable this feature to reduce the problem.

B.
Enable opCache on your server.
I've mentioned this in a previous reply but I've failed to see that it is not enabled on your server when you had shared with me the PHP info of your site. I'm sorry for that. You might need to contact your hosting provider to do that (it depends on your hosting plan). Our developers recommend having this PHP extension enabled. You can see again our documentation about how to improve performance here.
https://wpml.org/2012/01/can-your-site-run-faster/

Here are links that explain the OPcache.
hidden link
https://stackoverflow.com/questions/17224798/how-to-use-php-opcache/17304671#17304671
https://stackoverflow.com/questions/22773041/is-my-opcache-running

Kind Regards,
Itamar.

March 5, 2018 at 9:01 am #1535864

fulvioP

Hi Itamar,
I disable the string option thatyou tell me, now it's a little bit better.
I check and you can check too the phpconfig and the opcache is enable.
Any other things ?

Thank you

March 5, 2018 at 10:20 pm #1536960

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

No, I'm sorry I do not think that OPCache is enabled on your server.
When it is enabled, you should see the Zend OPcache extension section in the PHP info.
And you will also see the first field that confirms that it is enabled.

Opcode Caching 	Up and Running

Please see attached screenshot of how it looks when it is enabled.
Please ask your hosting support about it as well.

Regards,
Itamar.

March 6, 2018 at 7:09 am #1537165

fulvioP

Hello
I'm sorry Itamar, host support call me again and tell me that mine is a shared server and is not possible to setup an opcache.
I test the website many times now on gtmetrix and now all is better but not the Yslow.
I have 2 issues :
1) Do you think a CDN real take us advantages ?
2) I found in the waterfall tab 2 images with 404 not found and too much time on server searching... where I can remove these calls? (in attachment)

Thank you

March 6, 2018 at 11:32 am #1537505

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I'm glad that now things are better.
You write: "...but not Yslow."
What do you mean by that?
Also, I'm not sure what you are asking me in questions 1 and 2 and if it is related to WPML.
Can you explain, please?

Thanks,
Itamar.

March 7, 2018 at 4:35 pm #1539474

fulvioP

Hi,
I'm sorry you're right last message are not for you.
Anyway now all it's better but not the backend.
I found too much time with and without wpml active on loadind backend pages.. so how you can solve this?

Thank you

March 8, 2018 at 11:53 am #1540419

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I'm sorry, but debugging the performance of your back-end that is showing slow loading even when WPML is deactivated, would be out of the scope of this forum.
At this point, I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/
Before doing so, please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

You will get the custom assistance you need to get on with your project.

Best Regards,
Itamar.

March 9, 2018 at 8:09 am #1541458

fulvioP

Sorry I don't explain me well :
my backend is really slow only with wplm active.
Without wpml is ok. You can check it.
Let me know.

Thank you

March 12, 2018 at 10:06 pm #1544138

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've installed the Query Monitor plugin on your site and visited a few backend screens, and they load quite normally and even fast.
For example, I've visited the Strings Translation screen, and it loaded in less than 2 seconds. Please see attached screenshot.
Can you see that it is loading fast now?
If you have any backend page that you think is loading very slowly, please let me know so I can check it.

Thanks,
Itamar.

March 13, 2018 at 9:20 am #1544480

fulvioP

Hello,
in attachment you can check some slow loading time.
Please check them.
thank you

March 13, 2018 at 7:58 pm #1545223

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

If you are using a shared hosting server then it might explain differences in loading times in different hours of the day. Other factors might also influence that. When I check the pages that you show in your screenshot, I get shorter loading time. Less than half of the time and sometimes around 3 seconds. But still, even the loading times that you show are quite normal for backend pages when WPML is installed. I've supported many performances tickets and the loading time that you have on your backend is quite normal. You should understand that WPML is a complex plugin that sometimes needs to send many queries to the DB. Our developers are constantly improving WPML's performance, and indeed it is getting improved from version to version. Again, if for example, I take the Strings Translation page on your site it loads for me in 3.2 seconds which quite normal. And when I analyze the loading time I see that WPML takes about half of the time. Please see attached screenshot. But still, in overall, this is normal loading time. Loading time of backend pages do not have an effect on SEO.

I hope that my explanations are clarifying the issue.

Regards,
Itamar.

March 21, 2018 at 10:30 am #1552008

fulvioP

Thank you Itamar,
but I try in different times and is always slow.
With wpml not active all is ok.
Maybe you can do something on a new version?
Because now that timing is not acceptable.
Thank you