This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Andreas W. 5 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
May 7, 2019 at 7:53 pm #3761663

henryM-3

I am trying to: I have followed the WPML Custom Field translation guide. But the translations do not appear on the second language page. I am translating from English to Spanish.
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see: When I switch between languages, the Additional information details from the English page should appear translated to Spanish on the Spanish page.

Instead, I got: They are completely gone when you switch to the Spanish page.

May 7, 2019 at 8:53 pm #3761953

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

I have reviewed the provided debug information and I did not recogniye any plugin for creating custom fields. Are those fields base don the theme?

Could you please go to WPML -> Settings _> Custom Fileds translation and check if the repective fields are set to "translate" or "copy"?

If so, could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 7, 2019 at 9:43 pm #3762301

henryM-3

Hi,

"I have reviewed the provided debug information and I did not recognize any plugin for creating custom fields. Are those fields base don the theme?"

Theses fields are created by the theme

"Could you please go to WPML -> Settings _> Custom Fileds translation and check if the respective fields are set to "translate" or "copy"?"

I have checked this several times and the ones that need to be translated are set to translate.

If so, could you please try to run the site in minimal setup to see if the issue persists?

Not sure exactly what you mean here.

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

I have disabled all the plugins and nothing changes.

Also please change to a default theme like Twenty Seventeen to see if the issue might be theme related.

Activating Twenty Seventeen erased all the widget settings and I was unable to see the ads. Now I must rebuild all the widgets.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
I have set the debug to "true" and added "define( 'WP_DEBUG_LOG', true );"

If you need, I'll be happy to send you the admin credentials.

Cheers,

May 8, 2019 at 7:39 pm #3770575

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 9, 2019 at 4:53 pm #3778211

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the credentials. This way I was able to make myself a better picture of the issue. it seems to me that the theme is not completely compatible with WPML.

Could you please install the theme to the following test site in order for further testing in order to escalate the issue to our compatibility team?

One Click Login: hidden link

Please leave me a short notification once the theme is installed.

Kind regards
Andreas

May 9, 2019 at 6:35 pm #3778769

henryM-3

Hi,

I have installed the theme and the WooClassified plugin.

May 10, 2019 at 10:41 pm #3788005

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you to let you know that I am still working on the issue and I could not find out yet, why the custom fields are not getting displayed on the translated page. I will contact you again about this issue on monday.

Futher, I realized two different issues on your site that refers to problems between the currently used theme and WooCommerce. (See screenshots)

- One of the WooCommerce Templates is outdatedand asking for manual update. (See WooCommerce -> Status)

- I translated the test product at WooCommerce -> WooCommerce Multilingual -> Products and received an error which refers to issues between Classipress and WooCommerce when calling up the product page.

I would advise you to contact the WooCommerce and the Theme Support about this issue in the meantime.

Thank you for your patience.

Kind regards
Andreas

May 11, 2019 at 12:50 pm #3790547

henryM-3

Thanks. I will contact them.

May 14, 2019 at 3:17 am #3803007

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank tyou for your patience.

I have tested the issue on a new installation of WordPress using the ClassiPress Theme and WPML at its latest version.

The listing options have been translated as expected.

You can see the results here:
One Click Login: hidden link

It appears that the problem is caused due to another issue which might be caused by coding errors or incompatibility with another plugin.

Let me know if you will need any further assistance from our side.

Kind regards
Andreas

May 14, 2019 at 11:37 am #3806399

henryM-3

There are no ad details in the ad that you created. I have created a second test ad by clicking the post an ad button and the details do not appear in either ad in English or German. The issue that I am having is that the ad details do not appear on the Spanish translated page when you switch languages.

The issue seems to be with the form properties. They are not translating. I have created a test form the demonstrates the issue.

- In the Dashboard on the English page go to Ads > Forms and then one the far right, click the second icon on the right. It is the form with the pencil next to the red X.
- Once there, check the checkbox labeled Misc under Available Categories.
- Now if you view the ad, the additional details will appear. They do not appear on the German page.

I don't remember where or how I translated these custom categories, but I trnslated them on my site. When de activated the ClassiPress - Single Listing Map and Contact info widget in the Single Listing Side Bar, the details stopped working.

As of now, the details appear on the Test Ad 2 and not the German translation of the ad.

May 14, 2019 at 3:15 pm #3808623

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the clarification.

I was able to make the custom fields available on the Classic Translation Editor after adding a custom XML config at WPML -> Settings. Anyhow, the translated fields will not show up on the translated ad.

The issue has been escalated to our compatibility team who will investigate and work on a solution. I will be in contact with you as soon I receive feedback.

Kind regards
Andreas

May 14, 2019 at 3:30 pm #3808723

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have been informed that AppThemes does offer a "WPML Bridge Plugin" to solve the issue. Once activated, go to Ad -> Forms and edit the form then choose the translated category. This will fix the issue.

You should be able to download it here:
hidden link

Kind regards
Andreas