Skip Navigation

This thread is resolved. Here is a description of the problem and solution.


The menu language switcher doesn't appear in the website frontend


Add the language switcher for the right menu from the WordPress Dashboard > WPML > Languages > Menu language switcher settings.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by mennoB-4 11 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 1, 2019 at 9:26 am #4670193


I am trying to:

add a language flag in WordPress

Link to a page where the issue can be seen:

hidden link

I expected to see:

The flag for english lang.

The flag works in the old menu but not works in the new menu

Instead, I got:

no flag

October 1, 2019 at 11:51 am #4671745

Please It's possible to reopen this ticket?
The ticket is not resolved


New threads created by Andreas W. and linked to this one are listed below:

October 1, 2019 at 6:34 pm #4674691

Marcos Vinicios Barreto

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)


Thank you for contacting WPML Support. I took a detailed look in your menu language switcher issue and noticed your pages don't have any completed and published translation, in these cases the menu language switcher is not visible as you don't have translations to access.

I created a test page and the language switcher appears properly as you can confirm at: hidden link. Here are the steps I tried to fix the issue:

1 - I created a test page called 'WPML Support Test' and added a translation for it in your WordPress Dashboard > Pages settings.

2 - I edited your menu language switcher and attached the WPML Language Switcher to the 'A-infoplazaNL V2 MEGAMENU' menu in your WordPress Dashboard > WPML > Languages > Menu language switcher settings, since it is the menu you assigned for your website in your WordPress Dashboard > Appearance > Menu settings.


Please, let me know if you need any addition assistance and clarifications, have a nice day.

October 3, 2019 at 8:40 am #4685877


My issue is resolved now. Thank you!
Thanks Marcos,
but didn't work before in translated pages