This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to show a page link in another language menu?

Solution: There are two ways to do this.

1. Make a duplicate page in Dutch Just click on the + sign here http://take.ms/rWyGc and make a duplicate of the page. Now, this will appear in your Dutch menu and it won't affect your SEO. WPML will tell the google that this is a duplicated page. You can translate it later whenever you want.

2. Use custom links options Copy your English page URL and use it in your Dutch menu custom links option. To get the custom link option you have to enable the option from the menu screen options. Screenshot: http://take.ms/37LmW

This topic contains 2 replies, has 2 voices.

Last updated by stevenM-21 12 months ago.

Assigned support staff: Riffaz.

Author Posts
October 18, 2018 at 5:54 pm #2829141

stevenM-21

Hello,

Is there a way to add English pages to our Dutch menu. We are not going to translate everything and currently we can only add the translated pages to the menu.

Thanks for you help

Steven

October 19, 2018 at 8:49 am #2831175

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Steven,

Thank you for contacting WPML support.

There are two ways to do this.

1. Make a duplicate page in Dutch
Just click on the + sign here hidden link and make a duplicate of the page.
Now, this will appear in your Dutch menu and it won't affect your SEO.
WPML will tell the google that this is a duplicated page.
You can translate it later whenever you want.

2. Use custom links options
Copy your English page URL and use it in your Dutch menu custom links option.
To get the custom link option you have to enable the option from the menu screen options.
Screenshot: hidden link

Let me know the results, please.

Regards,
Riffaz.

October 23, 2018 at 9:10 am #2841650

stevenM-21

My issue is resolved now. Thank you!