This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by niekv-4 5 months ago.

Assigned support staff: Noman.

Author Posts
May 13, 2019 at 6:59 am #3795527

niekv-4

I want to try to add an language, which should not yet be visible in the language switcher on the frontend because we want to add the translations before publishing it.
Is this possible and how can we do that?

May 13, 2019 at 7:37 am #3795711

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. Yes, it’s possible and you can hide any language from WPML >> Languages >> Hide Languages and this will hide the languages and allow you to keep working on them and they will not show up in the front end.

If you want to enable hidden language content for current logged in user then you can achieve it by selecting ‘Display hidden languages’ checkbox from your Users >> Your Profile.

Please let me know if this resolves your issue or you need further assistance.

Thank you

May 13, 2019 at 8:22 am #3796021

niekv-4

My issue is resolved now. Thank you!

May 15, 2019 at 12:08 pm #3816193

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

[ changing ticket status ]

May 15, 2019 at 1:08 pm #3816693
niekv-4

We have setup custom domain names for both languages (eg site.com and site.nl) for the french we are gonna do that to, and I have set an temporarily domainname for the french language. The WPML check says it's 'OK', but when navigate to that domain it is redirecting it to the dutch (default) language.
Is there an way to visit the french site (with or without the custom/temp. domainname) when the language is still not publiced? (Im logged in as an user which is allowed to see the french language)

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/custom-domain-name-is-redirecting-to-the-dutch/

May 15, 2019 at 7:43 pm #3820005

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Thanks for getting in touch. To handle this new issue, I have created a new ticket since this is a separate issue and we will try our best to help you there. Here is the link to the new ticket: https://wpml.org/forums/topic/custom-domain-name-is-redirecting-to-the-dutch/

Thank you for your cooperation and patience.

May 16, 2019 at 8:47 am #3823359

niekv-4

This issue is resolved, will continue in new ticket.