This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.11 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Itamar 2 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
February 15, 2018 at 7:00 am #1518465

Richard Seres

I am trying to: cleared cache, turned off all plugin and i saved permalinks and turned on all plugin (somebody said it can help)

Link to a page where the issue can be seen: hidden link

So the main problem is, add item to cart takes 15 sec with wpml, without it about 1 sec. Do you have any idea what can help?

February 18, 2018 at 7:01 pm #1521383

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hello.

I can see the issue on your site.
Products do get around 15 seconds to be added to the cart.

I would like to ask you to check the following, please.
Please, make sure that the following settings are OFF or disabled
- 'Adjust IDs for multilingual functionality' (WPML -> Languages -> Make themes work multilingual).
- 'Track where strings appear on the site' (WPML -> Strings Translation)
- 'Auto register strings' (WPML -> Strings Translation). Unselect strings from all text domains.

You also mention that you have cleared the cache on your site, but I can not see any caching plugin on your installation.
Can you please tell me which caching methods are you using?
We do recommend to use a caching plugin to speed the performance of the site and also checking on the server.
Please read our following article 'Can Your Site Run Faster?' and see if you have implemented all the pieces of advice that are suggested there.
https://wpml.org/2012/01/can-your-site-run-faster/

Thanks,
Itamar.

February 19, 2018 at 7:05 am #1521580

Richard Seres

Hi, i turned off everything and the problem not solved. Yes i cleared the cache but after this i turned off the cache plugin (but didnt help btw it was the 'wp super cache' plugin). I think there will be the problem with the queries number, when i add item to cart they queries number are too much.

February 20, 2018 at 12:43 pm #1523541

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You write: "I think there will be the problem with the queries number, when i add item to cart they queries number are too much."
Could you tell me please, how do you identify that?

Besides that, I want to ask you if PHP Opcode Cache is enabled on your server?
You can read more about it at the following link.
hidden link
You can look it up in the PHP Info page of your server.
Can you, please also share the PHP info of your server with me?
You can follow the below instruction on how to get this information.

1. To create a phpinfo file, open a plain text file, add the following lines, and save:
Filename: phpinfo.php

<?php

// Show all information, defaults to INFO_ALL
phpinfo();

?>

2. Upload the file to the server. You should upload your file to the exact directory you want to test. Typically, this will be your httpdocs (/var/www/vhosts/example.com/httpdocs/) directory, although you can upload it to any subdirectory on your server as well. Use FTP to upload the file.

3. Visit the page in your browser. If you uploaded it to your html directory, you should now visit hidden link, replacing example.com with your domain name.

4. Now you can view all of the information about PHP for your server for that particular directory.

5. Tell me when it is done so I can watch this info as well (you can share the link with me).

Please read more about it here.
hidden link

Also, the performance of the site also depends on the hardware that your server uses.
Do you have any information about that that you can share with me?
Frequently, shared hosting plans are using low hardware technology.
For instance, are using a shared hosting plan?
If you do not know the answer to those questions, maybe you can find out about it with the support of your hosting company.

Thanks,
Itamar.

February 20, 2018 at 12:59 pm #1523573

Richard Seres

Hi, i uploaded the file. Here is the link: hidden link

February 21, 2018 at 1:08 pm #1524896

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thank you for sharing the php.info
I'm discussing this issue with our second tier supporter, and I'll update you here when I have a reply from him.

Thank you for your patience,
Itamar.

February 21, 2018 at 5:59 pm #1525289

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks,
Itamar.

February 28, 2018 at 11:35 am #1531651

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thank you for creating the test site.

I've escalated this issue to our second tier supporter.
We will keep you updated here.

Thank you for your patience,
Itamar

March 5, 2018 at 6:57 am #1535736

Richard Seres

Any news?

March 6, 2018 at 9:45 am #1537376

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I have no news from our second tier about this issue.
But I've re-examined the PHP info of your server and found that the OPcache extension is not enabled on your server. This is something that our developers will recommend to enable to improve site's performance. I've already mentioned this issue here, and you can read about it in our documentation here. https://wpml.org/2012/01/can-your-site-run-faster/. Please ask your hosting support to enable this option on your server. When it is enabled, you can see the Zend OPcache section when you watch the PHP info page. Please see attached screenshot.
Here are links that explain the OPcache.
hidden link
https://stackoverflow.com/questions/17224798/how-to-use-php-opcache/17304671#17304671
https://stackoverflow.com/questions/22773041/is-my-opcache-running

Can you, please enable the OPcache on your server and see if it helps?

Regards,
Itamar.

March 13, 2018 at 8:17 am #1544365

Richard Seres

OPcache is on. 🙂

March 13, 2018 at 9:17 am #1544465

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks for enabling the OPcache on your server.
I've sent a notice to our second tier about it.
We'll keep you updated here.

March 14, 2018 at 9:23 am #1545588

Richard Seres

Okey, thank you! 🙂

July 21, 2019 at 2:34 pm #4252501

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry for not getting back to you for such a long time. If you are still experiencing this problem with the latest versions of WPML and its add-ons please let me know about it. Otherwise please mark this ticket as resolved.

Best Regards,
Itamar.