Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by david 7 years, 2 months ago.

Assigned support staff: sarah.n.

Author Posts
July 29, 2013 at 12:52 pm #149694

david

I have a wpml and WooCommerce site
With different domain per language.

hidden link ..for us
And
hidden link ..for Australia.

All Is working fine except when I want to add to cart a Australian product here
hidden link
I get this wrong url and page not found
hidden link
Way I get twice .au??

this is the same when i want to go checkout from here
hidden link
I get twice .au in the url?
hidden link

thanks
david

July 29, 2013 at 1:35 pm #149711

Bruno

Dear David,

You are using a redirection plugin? You could copy and paste the htaccess file here for me to look at?

Thank you.

July 29, 2013 at 6:14 pm #149801

david

Hi thank for your reply
I don't use redirection plugin

I have a wpml and WooCommerce site
With different domain per language
The Australian domain is alias (park domain (
All is fine except when I want to add to cart an Australian product or checkout like I explain above.

For some reason I don't have a htaccess file.

July 30, 2013 at 1:15 pm #150022

david

some one?
I need assistance

July 30, 2013 at 2:11 pm #150058

david

I found this in the forum i think it's the same issue
http://wpml.org/forums/topic/woocommerce-redirects-cart-to-checkout-in-default-language/
Also when i Deactivate WooCommerce Multilingual the problem disperse but I need WooCommerce Multilingual for different currencies.

July 31, 2013 at 11:03 am #150396

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello David,

This is Sarah. Bruno forwarded your forum thread to me so I will be assisting you from here.

May I ask you please to first update WPML and it's active add-ons to the latest bugfix release 2.9.1? See: http://wpml.org/2013/07/wpml-2-9-1-bugfix-release/

If the problem persists, can you please test using "Different languages in directories" and tell me what happens? (I am trying to isolate the problem therefore the request to test with a different "Language URL format")

Let me know please how you get on.

July 31, 2013 at 12:21 pm #150434

david

hello sarah,
I update wpml to 2.9.1 and no change.
In Australia product page
hidden link
Still get this wrong url with .au.au - when add to cart or checkout a Australian product
hidden link
also if I want to remove a product/item from the list in cart page
or update cart I get .au.au

but The links of the buttons in the small cart on the header are working fine
VIEW CART - hidden link
Checkout - hidden link

when I change to Different languages in directories its fine.
I get this ok url – add to cart
hidden link
and this for checkout
hidden link

Thank you
david

July 31, 2013 at 1:08 pm #150463

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

David,

OK one more thing we could try before we raise the "bug" flag.

Can you please install the WCML development version you can download from here: hidden link

Let me know when ready.

July 31, 2013 at 1:29 pm #150477

david

Ok this solves the Issue!!
thank you very much 🙂

So leave this WCML dev version and update it when there is an update?
can I ask you some more thing related to
Different Payment Gateways for different language?

Regards
david

July 31, 2013 at 1:39 pm #150492

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

David, this is wonderful!

Glad to hear that it now works. As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you!

July 31, 2013 at 1:48 pm #150501

david

ok.
thank you