If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 6 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 5, 2019 at 12:48 am #3741095

tamerm

I am trying to:add products to the cart of woocommerce

Link to a page where the issue can be seen:hidden link

I expected to see:all the products i added

Instead, I got:some of the products get added and some don't and this is in the default english language

May 6, 2019 at 10:24 am #3746985

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I think the issue happens when products are added simultaneously and in a quick manner. However, the issue cannot be reproduced when the products are updated one after another after waiting for the first product to be added to the cart.

I'm not sure if this issue is related to WPML can you please temporarily disabled WPML (this won't cause any data loss) try adding the products to cart swiftly, Are you able to reproduce the issue?

Please let me know the results.

Kind regards
Raja

May 7, 2019 at 11:48 pm #3762613

tamerm

Hello,
ok you do have a valid point but it still takes a longer time to be added to the cart when wpml is enabled, meaning i disabled it the wpml and the products got added within seconds but when wpml got enabled the first item got added fine but the second product was added within 2 minutes , so what might be causing that?

May 8, 2019 at 8:41 am #3764653

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

You have quite a lot of plugins. Maybe some other plugin is interacting with WPML, I have tested in the sandbox with just WPML I didn't notice any lag in the add to cart action.

I would request you perform a basic debugging. please, disabled all non-WPML plugins except WooCommerce and theme related plugins check if you can reproduce the same issue. If the issue cannot be reproduced enable the plugins one by one check if you can encounter the issue again this will gives us both a better idea and isolate any plugin interaction.

Please let me know the results

Kind regards
Raja

May 9, 2019 at 2:11 am #3771971

tamerm

Hello,
ok i will try that but it will take a while and i will get back to you,but when i tried today a product was supposed to added and it didn't it got added after the second time i clicked add to cart.

May 9, 2019 at 11:01 am #3775501

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure, Please try those steps, Usually these kinds are issues are related to the conflicting plugin. Those steps will eliminate a few other cases and helps narrow down the issue.
I will be awaiting your response.

Kind regards
Raja

May 11, 2019 at 2:55 pm #3790723

tamerm

Hello,
it seems to be working fine now , but this happens sometimes may be it related to timeout or something like that on the server, do you have any idea if there is a server setting that might be affecting the add to cart option?

May 13, 2019 at 10:19 am #3796813

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Glad you are able to conclude on this. The ajax option may fail in certain situation. When you can spot JS errors in your browser console. and the ajax return 500 error which is related to the server for this you might need to check the error log for the actual reason.

In the first case, try to use Google Chrome built-in console to see if there are any errors displayed when you try the add to cart action. You can access the console from your Settings > Tools > JavaScript Console. Keep the console open to check for any error while to add to cart.

Also, make sure the cache is cleared this can be a possible culprit when dealing with Add to cart operations.

Kind regards
Raja

May 13, 2019 at 11:12 pm #3802121

tamerm

Hi Raja,
ok i made what you did and cleared the cache and its working fine , i guess its related to the server.

May 14, 2019 at 6:10 am #3803885

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

That's great you are able to get into the details of the issue.
If the issue is related to server cache try excluding WooCommerce multilingual plugin from being cached. if you are using any specific cache plugin check with the plugin author on how to exclude specific plugins from being cached.

I hope that solves your issue.

Kind regards
Raja