This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.39 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The string '" Save my name, email, and website in this browser for the next time I comment."' doesn't get translated.

Solution: I wrapped the string (which is in functions.php file) in a gettext function, this way it can be translated using String Translation.

Relevant Documentation:

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2018 at 9:06 am #2220808

catherineR-3

I am trying to: Show the English translation for the checkbox "Oui, ajoutez moi à votre liste de diffusion." that shows up under my English blog posts.

Link to a page where the issue can be seen: hidden link

I expected to see: Yes, please add me to your mailing list.

Instead, I got: Oui, ajoutez moi à votre liste de diffusion.

May 24, 2018 at 7:26 pm #2225200

catherineR-3

There's now another element to this problem, but in reverse. In compliance with the new GDPR Agreement, I've activated default check box at the bottom of the comment form asking for permission to save contact detail:

Save my name, email, and website in this browser for the next time I comment.

The problem is this line shows up in English on the French posts! I translated the chain, but the problem remains.

May 24, 2018 at 10:10 pm #2226012

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please provide the steps you are following to add/edit the strings.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

3.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 25, 2018 at 5:57 pm #2231282

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I added the code to te wp-config.php, now it's working 🙂

I would like to ask your authorization to make a copy of the site in order to make further tests on a local environment without affecting the live site.

Also, I would like you to describe the steps to edit or find the string "Oui, ajoutez moi à votre liste de diffusion." in the site.

Regards,
Carlos

May 25, 2018 at 6:15 pm #2231461

catherineR-3

Hello Carlos,

Funny the code worked for you and not for me. I obviously did something wrong. Is this code something you suggest I leave in permanently? What impact does it have?

Yes, you have my authorization for the duplication, as long of course as everything is deleted afterwards.

As explained in my initial support message, you can find the said string at the bottom of all/any English blog posts. Here's a link to one:
hidden link

Was that your question?

Looking forward to your insight. Thanks.

May 25, 2018 at 7:44 pm #2231591

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Is recommended to leave the code to meet the WPML minimum requirements: https://wpml.org/home/minimum-requirements/

Thank you very much for your authorization.

Regarding the string. I can see the string in the frontend, my question is where can I find this string in the backend?

Regards,
Carlos

May 25, 2018 at 8:04 pm #2231677

catherineR-3

I have absolutely no idea!

Oh, wait, I think I might know, or at least point you in the right direction. This is generated by the plugin MailPoet 2 that I use for mailing out my newsletters. (The plain MailPoet plugin is also present, but I haven't started using it yet because I still need to sort out 3rd party sending business). There must be a setting somewhere regarding the possibility of adding a check box under the comment section allowing a user to simultaneously subscribe to the newsletter while publishing a comment. But I just can't find where this setting is...

May 25, 2018 at 8:18 pm #2231704

catherineR-3

Found it!
The option is in MailPoet, but in the MailPoet 3 (above MailPoet 2) > Réglages > Essentiels. There's a check box there about adding the string below the comment form. I guess I'll make the switch to this newer version of MailPoet, I'll solve the sending issue, si it's definitely worth solving the string translation issue.

May 25, 2018 at 8:29 pm #2231714

catherineR-3

I think I'm starting to understand why this string actually can't be translated. I think it's because the MailPoet plugin doesn't support translation. I'd have to enter a string with two languages, first in one, then the other. But that won't look very professional at all. It's a pity because I really like the plugin. Do you happen to know of a similar tool that works well with WPML?

May 25, 2018 at 8:44 pm #2231720

catherineR-3

For now I will deactivate this option in MailPoet. Would like a recommendation on a newsletter sending service that is compatible with WPML.

Now remains the more problematic other string that appears under the comment form that needs to be translated into French in order for my site to be GDPR compliant, the string "Save my name, email, and website in this browser for the next time I comment."

Do you see a way of translating this?

May 28, 2018 at 12:01 pm #2238211

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

It seems -unfortunately- that for now you need custom programming work which is beyond the scope of our support.

At this point I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

Before doing so please have a look also here:
http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

You will get the custom assistance you need to get on with your project.

I also recommend you to visit this link where you will find our official Multilingual-Ready Plugins list: https://wpml.org/documentation/plugins-compatibility/

Thank you very much for your understanding!
Best regards,
Carlos

May 30, 2018 at 7:08 am #2249181

catherineR-3

Hi Carlos,

Thank you for your message.

I understand about you not being able to help me translate the string associated with the MailPoet plugin. That plugin is not translation friendly.

However, I am very surprised the string associated with the main WordPress installation, which is now a requirement of the new GDPR agreement, should be something regular WPML support can handle.

Just to make sure we are on the same page, here, once again, is the string I need to translate at the bottom of my French blog posts:

" Save my name, email, and website in this browser for the next time I comment."

This string now appears by default when comments are activated on a WordPress site. But users of multi-language sites will be to be able to get this string translated!

Thank you for looking into this.

Catherine

May 30, 2018 at 7:33 am #2249220

catherineR-3

As a follow-up to this issue, I'd like to share info I received from the Beaver Builder Theme Support Team. Initially this new required check-box wasn't appearing below my comment form. BB Support replied the following:

If your theme is passing arguments to the comment_form() function ( which bb-theme does btw ) you will need to add this to your child theme:
hidden link

Its a wp core bug which can be tracked here https://core.trac.wordpress.org/ticket/44126

Since adding this code to the functions.php file, the string is appearing. But now it needs to be translated. The string does appear in the normal WPML string translation tool, but it's not applying my translation. See attached screenshot.

I'm certain many other uses will be having the same problem.

Thanks for keeping me updated.

C.

May 30, 2018 at 7:49 pm #2253155

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Catherine,

I made a small change to the code in functions.php of the child theme to make the string translatable. I scanned and translated the string already.

Could you confirm that the string is translated correctly?

Best regards,
Carlos

May 30, 2018 at 7:54 pm #2253160

catherineR-3

Thank you very much Carlos, the translation is perfect. The fix to the code works like a charm!